Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Here's the background: I use a Macbook from this year and run VMWare Fusion (newest update). One of my VM's is Windows XP Professional. Two times recently, I have brought up the VM window to see that it has decided to shut down and is at the "Windows is shutting down" blue screen (not bsod). At this point it seems like using the menu drop down "Shut Down" does not work. The first time, I was able to force quit fusion (suspending the VM) and then come back in and shut it down from menu, but this time, no luck.

Is there any way to "pull the power" on the VM?

Please also answer if you know what might be causing the VM to decide to shut down (besides windows update) or what it might be "thinking" as it hangs mid-shutdown.

share|improve this question
Try in VirtualBox. :P – Breakthrough Aug 21 '09 at 14:09
I appreciate the alternative option, as I did not know about VirtualBox, but my goal is to get to the files more than anything. – TahoeWolverine Aug 21 '09 at 19:41
up vote 11 down vote accepted

Try using the vmrun utility included with VMWare Fusion. Launch the VM in Fusion and execute this command (in a Terminal window) to make vmrun can see it:

/Library/Application\ Support/VMware\ Fusion/vmrun list

If the problematic virtual machine shows up, run:

/Library/Application\ Support/VMware\ Fusion/vmrun -T fusion stop "/path/to/.vmx" hard

That should shut it down immediately.

share|improve this answer
You sir, deserve to be the VMWare Major. – DFectuoso Sep 30 '10 at 2:56
Four years later, I know, but vmrun moved into the App bundle: /Applications/VMware\ Just wanted to let other people know who found this page years later like me. – getWeberForStackExchange Jul 17 '13 at 10:14
@weberwithoneb Oh, good catch. You should submit an edit to the answer. – Sidnicious Jul 17 '13 at 23:25

Thought I'd chime in with my QSW results so they may help teh next.

While THIS thread has the SERP, this thread has teh solution:

Hold down the Option Key > Click Virtual Machine > See teh Power Off option > Click it.


share|improve this answer
This worked a treat for me. Thanks! – Carl Sep 20 '10 at 4:26

This worked for me:

If you have snapshots enabled, roll back to a previous snapshot.... even better if you AutoProtect enabled so that you can get a fairly recent snapshot. My AutoProtect takes a snapshot everyday.

share|improve this answer

You can move the .VMEM file out of the folder that contains the virtual machine. Then when you try to resume the virtual machine, it'll say it can't find it and if you want to discard the suspended state. It should then boot up.

I just tried this on mine and it worked. Wouldn't hurt to back up first though. :)

Once you get Windows booted up, check the event log for what might be causing it.

share|improve this answer
I moved the file and now get an error when trying to open: Cannot open the disk 'Documents/Virtual Machines.localized/Windows XP Professional.vmwarevm/Windows XP Professional-000003.vmdk' or one of the snapshot disks it depends on.Reason: Failed to lock the file. Where do the snapshots live? – TahoeWolverine Aug 24 '09 at 1:12
Hmm... you moved the .VMEM file, right? That's where it stores the RAM to disk. Was there a .VMEM.LCK file along with it? I moved all the LCK files out as well during my test. If this is a no go, I'd move all the files back before continuing. The VMDK file is the virtual disk. Snapshots would probably be in the same folder, but I'm not using snapshots, so I can't verify that personally. So, it looks like there are snapshots on your VM. In the menu on top, does it let you look into Virtual Machines -> Snapshots? It's starting to look like some VM corruption is the problem. – emgee Aug 24 '09 at 23:28
Can you please list the directories that you're dealing with? Thanks. – TahoeWolverine Aug 24 '09 at 23:31
My currently suspended Windows XP VM: ~/Documents/Virtual Machines/net/ ---> Applications (folder), net.vmdk (document), net.vmem (document), net.vmem.lck (folder), net.vmsd (document), net.vmss (document), net.vmx (document), net.vmx.lck (folder), net.vmxf (document), nvram (document), various logs. – emgee Aug 25 '09 at 3:40
All that is in my VirtualMachines directory is the image itself, and Applications has only applications, no files. – TahoeWolverine Aug 25 '09 at 6:12

The best shut-down option is definitely going to Virtual Machine and selecting, "shutdown guest" - a bit confusing if you have a profile named "Guest", but it means the running profile, regardless of which one. An additional way to mitigate the problems related to the hang-up of VMWare, although not a full solution, is that when you are in Windows XP, go to Start/Run then type in 'CMD' bringing up a command window. type, 'cd\' to go to the root. There, type 'chkdsk /f'. You'll be told Checkdisk cannot be run and do you want to run the operation the next time you reboot. Answer 'Y' and the next time you boot, (best to just go at that point and select restart so you don't forget!), the Windows Check Disk will run and fix any errors it finds which may be contributing to the reason you are getting hung up in the first place. The reason I'd been experiencing this issue seems to have had something to do with running Thunderbird from a USB thumb drive and having windows experience a 'Write delay failure' where the data couldn't be recovered. I run Win XP Pro on a MacBook Pro with VMware 2.0.8 (328035).

share|improve this answer
I appreciate the answer. I long since stopped using this VM so I can't verify that your solution works, but it's definitely valuable info in this context. Thanks. – TahoeWolverine Aug 9 '11 at 19:58

I used the link provided by Jimi (kthanxbai) above and it worked great. (Thank you!) My XP VM was hanging on the shutdown screen. I tried to follow the brief instructions given by Jimi above but w/o success. Then when I followed the link (he provided) to get more detailed information, I was able to "power off" the VM with no trouble at all.

The trick is to click on "Virtual Machine" in the VMware menu and keep it active/open/expanded while you click and hold the 'option' (alt) key on the keyboard. This will cause the options on the drop down "Virtual Machine" menu to change. 'Shut down' will change to 'power off'. Click on 'Power off' to fix the problem. I had some difficulty trying to hold the menu down, depress the 'option' key, click on 'power off' but once I did those things in succession, the problem was cleared instantly.

Thanks very much for the solution.

share|improve this answer

To force a virtual machine to power off:

1.From the Fusion menu bar, click and hold on Virtual Machine.

2.Press and hold down the Option (Alt) key. The menu option for Shut Down changes to Force Shut Down. (In Fusion 2.x and earlier, it changes to Power Off).

3.Click Force Shut Down. (In Fusion 2.x and earlier, click Power Off).

share|improve this answer

It sounds like it may possibly be a corrupted VM. To effectively "pull the power" would be to get a TERMINAL window open on the MAC and you would have to know which VMWARE processes to use the kill command on. I do NOT know which processes you would need to kill. VMWARE support or Google would help you out.

Do you have a snapshot or CLONE of your VM? If so, I would try another "copy" of your VM. Have you made any configuration changes to your VM lately? In the future I would clone that sucker when it's working great then you will always have something to fall back on when stuff like this occurs.

share|improve this answer
No previous snapshots (doh) and killing processes doesn't work (at least from activity monitor). – TahoeWolverine Aug 20 '09 at 1:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.