Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
static IP not ping from outside

Hi, I have took a new broadband connection, and I got new static IP. I have 4 linux machine and 1 vista machine and 1 switch. I have joined my internet connection to the switch and all 5 machine are connected to switch. Now if I giving my static IP to any one of my linux machine then this static IP is pinging from outside my local network, but when I give the same static IP to my vista machine (I had remmove static IP from linux machine), the static IP is not pinging from outside my local network.

Before taking new broadband connection, I had wireless connection and 1 dynamic static IP on my vista machine, and that time this static IP was pinging from out side my local network.

so what is wrong now? why my new static IP not pinging from outside? Please reply me as soon as possible, if any one knows solution for this.

share|improve this question

migrated from stackoverflow.com Jan 25 '11 at 11:06

This question came from our site for professional and enthusiast programmers.

marked as duplicate by ChrisF, Diago Jan 25 '11 at 13:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I think you got confused, I dont think you can have "1 dynamic static IP". My advice is to get a router, switches have failed on me way too many times when setting a network. (Im not a network guy so dont think I know too much about this :P) –  Purefan Jan 25 '11 at 10:09
    
@Purefan: It's clear you're "not a network guy". Switches and routers serve two completely different purposes. You can't just make that general recommendation. –  Cody Gray Jan 25 '11 at 10:13
    
@Lokesh: Your Vista machine has the firewall enabled. Turn it off, and everything will be just like your unsecured Linux machines. –  Cody Gray Jan 25 '11 at 10:13
1  

2 Answers 2

Cody is right, the Firewall blocks the Ping request on Windows Vista by default. Rather than just disabling the Firewall altogether, you can just allow Ping (or ICMB Echo, as they'Re more formally called) requests to go through the firewall. To do this, open a command prompt as Administrator and type this:

netsh firewall set icmpsetting 8 enable

Also, I'd recommend you to get a router. Right now, at least one of your machines is on a public network, and that's no good if you want that machine to be functional on a local network, i.e. if it should have network shares and the like.

share|improve this answer

Does the Vista firewall allow pinging from non-local machines?

I don't quite understand what you are trying to achieve, given several machines on a single broadband connection it would be more usual for the Router to have the single static IP, and for the local machines to use NAT, with port-forwarding in the router to allow any required inbound connections to specific machines. How are the remaining four machines connecting to the outside world? Are you using one of them as a router? (in which case I'd definitely be using a Linux box and not Vista!)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.