Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange problem with the internet access of 3rd party programs. Whenever I want to update a program, it cannot access the update server and gives an error complaining about the internet connectivity (cannot connect to the update server). However, I have no problem with Windows updates which are downloaded and installed automatically. I closed down the firewall, antivirus and UAC, tried again and no luck. The only possibility I can think of is the proxy server of our company.

Last year, IT has set up a proxy server and changed the LAN configuration on our PCs. Without the following setting done, no one can connect to the internet:

Assume that the name of our company is XYZ. We have both .com and .com.tr domains.

LAN settings

The setting is under Internet Options > Local Area Network (LAN) Settings. A similar setting is needed by Firefox. Under Options > Advanced > Network > Settings, the following setting is present:

Firefox network settings

At that time, we were using old laptops with Windows XP SP3. There was no problem at all. Now we have new laptops with Windows 7.

How can I diagnose and confirm that the problem comes from the global proxy settings, if there is any; and how can I fix that? What steps should I follow?

share|improve this question
    
I assume those 3rd party applications don't offer a "network settings" dialog? –  Tobias Plutat Jan 25 '11 at 13:06
    
@Tobias: agreed. i also reckon the traffic only goes thru the set up browsers (i. explorer thus windows itself can update). for instance, try to use skype or your antivirus with your proxy address entered. –  sterz Jan 25 '11 at 13:21
    
@Tobias: While using Win XP, there was no problem. I never changed settings for these apps. For example, Notepad++ doesn't have any network settings dialog. –  Mehper C. Palavuzlar Jan 25 '11 at 13:51
add comment

1 Answer

There's two things I think you can do here*:

Change the "Internet Settings" in Windows/Internet Explorer (I guess that's what the upper screenshot shows) to the same values as in Firefox, assuming Firefox works. That is, remove the "detect automatically" and "automatic proxy script" checkmarks and check "Use Proxyserver for LAN" and "Don't use Proxy server for local addresses". Under "Address" and "Port", fill in the same values as in Firefox.

See if you still have internet connectivity in Internet Explorer. If so, every program that adheres to Windows' internet settings should now work just fine.

However, you'll have to check for network settings in each program you want to have connectivity. Not all of them determine proper values automatically, so watch out.

*Please note I'm actually guessing the descriptors in the menu here. Neither the OP nor me have an English version of Windows, so there you go...

share|improve this answer
    
I did as exactly you said, and restarted the machine for convenience. Notepad++ still can't connect to the server. Since its setup file needs internet connection, I also tried to install "Windows Live Essentials" (wlsetup-web.exe). It waited for 5 minutes and said: No internet connection. IE works fine BTW. –  Mehper C. Palavuzlar Jan 25 '11 at 14:31
    
On reflection, it's also entirely possible that your company IT dept. has some policies in place on the proxy server. –  Tobias Plutat Jan 25 '11 at 14:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.