Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed a dozen dual boot XP / Ubuntu boxes, however this one has me stumped. After the installation failed in the partitioning phase I tried manually partitioning using a Gparted LiveCD. I can resize the NTFS partition fine each time rebooting in XP and it is OK.

However when I shrink the NTFS then try to add an ext4 (or ext3) right after the NTFS it acts like it is working, then when it says "complete" the disk disappears out of Gparted and it shows no devices. If I reboot into the LiveCD it shows a blank second partition, if I try to format it in ext4 I get the exact same results. If I go to Windows it will show an unknown healthy partition.

If I grow the NTFS back to the full 60Gb it seems to work fine. It just won't create a second primary ext4 partition.

Any ideas on where to go next?

share|improve this question
1  
How many primary partitions are on that hard drive, you are only allowed 4. –  Moab Jan 25 '11 at 15:22

2 Answers 2

So... if I understand this correctly, you installed XP on a 60GB HDD, then shrunk the partition with XP on it, and lets say you shrunk it to 30GB (with GPartEd). After you shrunk it, you formatted the rest of the space as ext4(with GPartEd). And even after you shrunk the NTFS partition, windows would still boot, but the ext4 partition was acting as if it were corrupt?

If that is correct, I would then proceed to booting back into GPartEd and deleting the ext4 partition. I would then put the Ubuntu disc in the computer and install it on the unallocated space. Then, the OS would format the drive itself and it should not mind the unpartitioned space. GPartEd might be formatting the drive in a way that Ubuntu thinks it is currupt. Windows will probably not be happy(but still function perfectly) with an Ext4 partition on the HDD (when viewing it through disk management)

share|improve this answer
    
Good idea. However when I go to install, it doesn't see anything in the blank space so I go to advanced partitioning. Try to create a new partition and the installer complains that "couldn't satisfy all constraints" of something like that, then complains that kernel won't see changes and offers a cancel / ignore which it then won't even respond to. –  Dennis Jan 25 '11 at 14:32
    
Wow... That's messed up. Have you tried formatting the other space (non-XP partition) as something other than Ext3 or Ext4 @Dennis? –  David Jan 25 '11 at 15:02
    
Yes, every thing I try basically goes through the motions, says it was successful, then the drive area in Gparted goes blank, at the bottom says "no devices found" and when I reboot it is basically as before. The odd thing is that it was able to create the swap partition at the end of the drive. It just seems to be creating a partition after the NTFS that is a problem. –  Dennis Jan 25 '11 at 15:13
    
Did you try using a different version of GPartEd? Also, at this point, I would try using a tool to check the HDD for errors (bad HDD). Post back and let me know if the different version of GPartEd worked of if it is a bad HDD (or if anything else happens). –  David Jan 25 '11 at 15:32
    
I have tried the Gparteds on LiveCD, SystemRescueCD, Ubuntu 10.04 and 10.10, kind of assuming that they were different versions. Now I realize that I can format it in NTFS and FAT32 (I had tried other linux formats) fine and windows sees them. It only fails if I try to create an ext3 or ext4 –  Dennis Jan 25 '11 at 15:58
up vote 0 down vote accepted

All good thoughts and ideas from David. However this one was just a weird case that I should close out (since it resolved over a month ago).

It turned out to be a bad hard disk. Not sure why it reacted the way it did and why NTFS seemed to be forgiving (though it only appeared to work since a fresh windows install also failed) or why ext4 failed in the manner it did without more helpful information. But another hard disk worked perfectly and did everything you would have expected in a simple dual boot environment, and the original disk failed at all points in another laptop. It just seemed to start out ok then gradually completely failed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.