Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have locations in different cities, connected using 2 Cisco ASA devices.

my main location, corporate, use the IP 192.168.1.x The second location, remote store, use the IP 192.168.3.x

I have a DHCP server (192.168.1.254) at my corporate location. I have created a scope for the 192.168.1.x which works fine for the corporate location.

I created a scope for the remote location (192.168.3.x) on my DHCP server and tried to configure the remote ASA DCHP Relay,

on the remote ASA: I disabled the DHCP Server on the inside. I enabled DHCP Relay on the inside, with set route set at yes.

I set the Global DHCP Relay Servers, specify up to four servers to which DHCP requests would be relayed. I added my DHCP, 192.168.1.254

I flashed these settings to the ASA and gave it a try, didn't do anything.

am i missing something - forgetting something. not really sure what im doing wrong.

DHCP Settings on remote ASA:

dhcp-client update dns server both

dhcpd dns 192.168.1.254

dhcpd ping_timeout 750

dhcpd domain JEWELS.LOCAL

dhcpd auto_config outside

dhcpd update dns both

!

dhcpd address 192.168.3.2-192.168.3.33 inside

!

dhcprelay server 192.168.1.254 outside

dhcprelay enable inside

dhcprelay setroute inside

on my local ASA: i have two ACLs for UDP ports 67 and 68 permitting any inbound traffic from the remote locations IP ... dhcprelay timeout 120

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Ensure that you can ping your DHCP server address from your remote ASA. If you can, check to make sure you have the following commands configured on the remote ASA:

dhcprelay server 192.168.1.254 or your dhcp address outside

dhcprelay enable inside

dhcprelay setroute inside

dhcprelay timeout Enough time to reach server

share|improve this answer
    
yes - whenever i ping i get an immediate respone. i even tried tracert to the dhcp server, 1 hop. communication is perfect between the locations. however whenever i try an ipconfig /renew it says it cannot communicate with the DHCP server. i'm going to edit my original question with the DHCP config i pulled from a telnet session with the ASA. –  Jeff Jan 26 '11 at 18:01
    
also - the two locations are connected using site-to-site vpn .. –  Jeff Jan 27 '11 at 15:29
    
I had to add some additions to this (acls and nat translations for the remote store) don't remember exactly, cisco support actually helped with the setp –  Jeff Dec 22 '11 at 17:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.