Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install the Insight debugger on OS X. I can execute ./configure with no problem but when I try and run make it gets about half-way with no errors, but then starts spewing out errors(?) like:

../.././tcl/unix/../generic/regcomp.c:455: warning: passing argument 1 of ‘Tcl_Alloc’ with different width due to prototype`

Most of these end with with different width due to prototype

The fatal errors at the end are:

ld: library not found for -lX11
collect2: ld returned 1 exit status
make[3]: *** [wish] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-tk] Error 2
make: *** [all] Error 2

I have X11 installed as well as tk and wish. I've tried modifying the paths but the fatal errors still happen. Any ideas?

share|improve this question
1  
X11 != X11 development files –  Ignacio Vazquez-Abrams Jan 25 '11 at 21:37

1 Answer 1

To elaborate IV-A's comment a bit, most 'library not found' errors come about because you don't have the 'dev' files for the application installed. It's not enough to have the working application itself, missing libraries usually point to the omission of the development libraries for the package, in this instance X11-dev.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.