Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use a WD 1TB Sata2 HDD, on a USB docking base.

I started copying large files to this external Storage and went out.
When i got back home, there was a strange System tray message which i closed as i thought was nothing. The only words i vaguely remember are "optimized" and "performance"

Then i sadly discovered that the Disk is not accessible and Windows is prompting me to do a Format!

The System Event Viewer shows many occurrences of the following:

Source: Ntfs
The file system structure on the disk is corrupt and unusable.
Please run the chkdsk utility on the volume F:.

Source: Application Popup(but i see no popups)
Application popup: Windows - 
Corrupt File : Exception Processing Message 0xc0000102 
Parameters 0x000007FEFCF1715C 0x000007FEFCF1715C 
0x000007FEFCF1715C 0x000007FEFCF1715C

Source: Disk
The device, \Device\Harddisk1\DR2, has a bad block.

After a couple of restarts still the same. Then i tried to follow the chkdsk advice:

C:\Windows\system32>chkdsk F: /F
The type of the file system is NTFS.
Volume label is 1T.
Corrupt master file table. Windows will attempt to recover
master file table from disk.
Windows cannot recover master file table.  CHKDSK aborted.

The MFT is considered corrupt and could not be recovered by chkdsk.

Then i booted from Linux and got the same.
I couldn't mount the Disk because of MFT being corrupt.

The Data on disk are valuable to me. What do you propose instead of formatting?
Thanks in advance :-)

I ran the TestDisk but both MFT(MFT main & MFT mirror) were corrupt, so reconstruction is not possible. I googled some more, and right now i am into Data Recovery with Zero Assumtion Recovery, as suggested by TestDisk.

share|improve this question

No guarantees, but try Testdisk.

TestDisk can:

Fix partition table, recover deleted partition
Recover FAT32 boot sector from its backup
Rebuild FAT12/FAT16/FAT32 boot sector
Fix FAT tables
Rebuild NTFS boot sector
Recover NTFS boot sector from its backup
Fix MFT using MFT mirror
Locate ext2/ext3/ext4 Backup SuperBlock
Undelete files from FAT, exFAT, NTFS and ext2 filesystem
Copy files from deleted FAT, exFAT, NTFS and ext2/ext3/ext4 partitions.

share|improve this answer

TestDisk claims to be able to do what you want but I'm skeptical. I've never used it or heard of it before. It is open source so if you're brave, you could take a look at that to see what it does.

If the data is valuable however, take it to professional data recovery specialists. Can't stress this enough. Otherwise you're gambling with your data.

Edit: You've got 3 identical answers that have all come from Google. I'd still be skeptical until someone comes up with evidence that this will work.

share|improve this answer
If TestDisk doesn't do it, I guess the next option would be a hex editor or a Forensic Service. – Tom Wijsman Jan 26 '11 at 17:19

Maybe you can try running TestDisk on it:

share|improve this answer

Maybe try SpinRite?

share|improve this answer
What is this and what does it do? – KronoS Jan 26 '11 at 20:09
It scans your hard drive to see if it has any physical problems and attempts to solve said problems. – CajunLuke Jan 26 '11 at 20:12

I once had a disk that had so many bad blocks that it crashed Windows, even when it was only connected as a secondary (non-system) drive and even if connected after boot-up (SATA hotplug). It could not be accessed using Linux either.

What I did was make a block-by-block copy of the disk, using a free bootdisk called EASEUS Disk Copy. Once the data was copied onto a fresh disk, I was able to use data recovery software to recover around 90% of the files.

I highly recommend that you do this before your disk completely fails.

share|improve this answer

Try launching a DVD version of Ubuntu. I've had some success in the past accessing a drive.

share|improve this answer
I booted from my Linux partition, but the got the same error. It could not me mounted due to $MFT corruption. – athspk Jan 26 '11 at 21:54

I've recovered seemingly trashed / inaccessible drives before using a combintaion of cloneZilla or sometimes, if it's really bad, dd.

You can make a bootable clonezilla CD and use it to copy the drive contents to another drive if the broken disk has physical damage; if it's more the corrupt data that's the problem then dd may help.

Using dd does require a fair amount of *nix hackery experience, bewarned.


I'm not sure how much this will help but I've had alot of success in the past with these tools, hopefully your problem can be fixed. Good luck :)

Edit: Didn't realise this was so old, oops :)

share|improve this answer
It doesn't matter whether a question is new or old on Stack Exchange sites, as the answers are for more people than just the person who asked the question. – paradroid Jul 14 '12 at 13:15
yeah that's true, with any luck this will help someone else – jammypeach Jul 16 '12 at 8:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .