Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When my laptop comes out of sleep, I have to typically wait about 90-120 seconds before my network (wireless or NIC card) 'wakes up'.

During that time, I see my wireless connection with 'limited access' which means no access.

Eventually the wireless wakes up and connects, even if I have an ethernet cable plugged in and even when I am running on wall power.

In order to use the NIC, I have to disconnect from all my saved wireless profiles and then it is finally connected as a means of last resort.

I want to be able to wake immediately and connect directly to the NIC connection.

I have:

  • Dell Latitude E5510 w/8GB RAM
  • Windows 7 Ultimate
  • Broadcom NetXTreme Gigabit Ethernet
  • Intel Centrino Ultimate-N 6300 AGN
share|improve this question

migrated from serverfault.com Jan 26 '11 at 2:04

This question came from our site for professional system and network administrators.

1  
Why would you disconnect all the profiles? Isn't there just a switch on the front to disable the radio? –  Kyle Jan 26 '11 at 2:07
    
@Kyle: Actually, why not just go to Network Connections and disable the NIC? –  Hello71 Jan 26 '11 at 2:11
    
@kyle - no, only for bluetooth. @hello71, why would I? Shouldn't the hardwire be the default? Besides, I have the other problem of taking 90-120 seconds before I have ANY connectivity. Thanks for the help. –  jason Jan 26 '11 at 2:15
    
possible dupe of superuser.com/questions/234258/… –  tombull89 Jan 26 '11 at 16:08

7 Answers 7

up vote 14 down vote accepted

Try: Network and Sharing Center > Change Adapter Settings > Press and release Alt key to show the menu > Advanced > Advanced Settings

Move the LAN adaptor to the topmost position (This window says "Connections are accessed by network services in the order they are listed")

share|improve this answer
    
I don't know if this will help jason but you've definitely helped me find a useful setting that I've overlooked. :) –  Jeff Mercado Jan 26 '11 at 6:29
    
I was very excited to see this answer this morning, but unfortunately when I checked, the LAN is above the Wireless Network Connection already. –  jason Jan 26 '11 at 13:13
    
Update... just checked this again, and it is not. Go figure, lets see if this works now. –  jason Jan 9 '12 at 19:37

Go into your device settings. Look for your wireless card and go into properties, look fro advanced settings for the wireless card. Look for something like "Disable upon wired connect". Set this to enable. What this does is that if the system sees a wired connection with link, then the wireless card will automatically disable itself.

share|improve this answer
    
I don't have this option on my wireless card. Can you please provide a screen capture of your computer to demonstrate for us? –  user3463 Jan 26 '11 at 3:34
    
I don't have this option either... but it looked promising. ;) –  jason Jan 26 '11 at 13:15
    
I would vote it down, since it looks like a guessing/supposing answer. Not have a fact base. –  Teoman shipahi Sep 26 at 18:24

See my answer to this question.

You can set your laptop to "prefer" the ethernet conenction over the wireless. Technet has a quick overview:

The short answer is that Windows (Vista, 7, 2008, and I’m pretty sure XP and 2003 does as well) [or should do] this by default. The key here is the network interface metric. When you have more than one default gateway defined [...] then the internet bound packets go out the interface with the lowest metric.

[...] You can, of course, permanently alter your metrics by editing your TCP/IP settings on your network adapter’s advanced settings.

[...] You should know that Vista made a change to how we handle existing sockets – after plugging in, connections will not be switched over, you must re-establish the connection in order to make use of a wired connection. For example, if you’re downloading something from a website and realize that it would go faster by plugging in, you’d have to cancel and start over after plugging in. This is a change from XP and 2003.

For how to change these setting, have a look at this Microsoft KB article.

share|improve this answer

Your wireless "wins" because it starts slower.

As you noticed, the wired network comes up faster. This is because the network stack can see the DHCP server almost immediately. With the wireless, there's the whole AP selection, then authentication process which happens before DHCP can get started.

One of the things that the DHCP process does is apply a "default route". All things being equal, windows prefers the last-applied default route.

Which will end up being the wireless.

You can either manually turn the wireless off in situations when you prefer the wire (usually there is a physical switch or a Fn-key option for turning wireless on or off) or by forcing the wire connection to re-negotiate by pulling the wire out of the laptop for 5 or 10 seconds and then plugging it back in.

share|improve this answer
    
Wireless or wired, it still takes 90-120 seconds to start. If I open the laptop and immediately disconnect from all the wireless profiles, I still have to wait 90-120 seconds to connect by wire. –  jason Jan 26 '11 at 17:00

Have you tried Dell's support website to check for the latest wireless card driver? Sometimes updating the BIOS or the wireless driver can fix problems like this.

share|improve this answer
    
Yes, I have the latest, thank you. –  jason Jan 26 '11 at 13:16

I have to point out that even though wired mostly has a lower metric, the notification area still shows the wireless network connected symbol! Which is understandable, but might lead to confusion by many (it certainly confused me). Both LAN and Wireless can be available but only one connection is used (the one with the lowest metric)!

To see what is preferred, you need to look at the applied metric in the route table.

In elevated command prompt, run route print.
Look at the IPv4 Route Table section.
The first lines in that section will look something like this:

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      152.35.56.1     152.35.56.65     21
          0.0.0.0          0.0.0.0     152.35.156.1    152.35.156.15  10019
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306

Run ipconfig to see which of the first two lines is Local Ethernet vs Wireless connection. In my example, the Interface 152.35.56.65 is LAN, and the 152.35.156.15 is wireless. You see that my LAN interface has way lower Metric than the wireless (21 vs 10019). This means that the LAN is preferred since it has the lowest metric value.

share|improve this answer

weird... it wasn't until I set a manual metric of 1 on LAN and 9999 on wifi that I could have both enabled and see servers on the LAN. Even with adapter order set to LAN then wifi, and with automatic metric showing a higher value for wifi, a tracert still showed it trying to use the wifi gateway. Maybe a bug as you would think this should work without having to set things manually.

share|improve this answer
    
Did you have to restart computer before it had effect, or did it switch immediately? –  awe Oct 25 '13 at 12:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.