Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is the second time I've tried to change this setting on a Vista-based operating system and I can't get it to work again.

OS: Windows Server 2008 SP2 (not R2) = Microsoft Windows [Version 6.0.6002] = Vista

When I go to: Power Options -> Change Plan Settings -> Change advanced power settings -> Power buttons and lid -> Start menu power button -> Setting: the available combo box will only show the option Shut down. No other options are available.

  • This server is part of a domain and has not been set up by me.
  • I have not yet talked with the domain admin, but as far as I could tell from googling, only Win7 has group policy options for the start menu. (And yes, OC I will talk to the domain admin to see if he has any clue - which I doubt.) (Edit: I have now talked to our domain admin, and he's got no clue either.)
  • I'm responsible for this server and a local administrator but not a domain administrator.
  • I switched off User Account Control (UAC) yesterday without problems.

Since I always log into this machine via RDP and this being a server, the natural choice would be the option (Log out) and not (Shut down).

What can I do to fix it or to find out why it cannot be changed?

share|improve this question
up vote 5 down vote accepted

Solution has been found, see the end of my answer.

Troubleshooting to learn:

The grey box looks like the default behavior for a server, see our server configuration over RDP:

enter image description here

Looking into this further to get this fixed for you I see an alternative place where this can be configured:

enter image description here

But again, this doesn't allow us to change it so I'm going to look what registry key is manipulated on my laptop using Process Monitor, and apparently I can change this:


After trying a few time, the different possible values are:

  • 100: Switch User
  • 1: Log Off
  • 200: Lock
  • 4: Restart
  • 10: Sleep
  • 40: Hibernate
  • 2: Shutdown

Please note: You need to restart explorer.exe in order to see them in effect.

However, my laptop allows to change this, but the value is absent and doesn't work on servers. Thus they have hard coded this to come from somewhere else and you are thus unable to change it through the registry, so this made me wonder where the decision is based on... Aha, group policies!


You, or your domain administrator, can easily change this through the Group Policy Editor.

You can also shutdown quicker by pressing ALT+F4 and then it should say Log off by default so that you can press ENTER afterwards, all keyboard only. :-)

After further troubleshooting in the comments:

The solution seems to be to enable the classic menu (workarounds) so you can configure Log Off.

share|improve this answer
Side comment: For most computers, "high performance" doesn't mean what it says it means... all it really does is drain power. – Mehrdad Feb 2 '11 at 5:45
+1 for the great info you provide. // a) You are right Start_PowerButtonAction does not work on this server, I have just tried it. // b) Unfortunately, Group Policy only allows me to select one of Hibernate, Shutdown or Sleep -- it does not allow me to select Log off. -- Note also, that the site you link to writes: <quote>The last setting controls the power button located on the Start menu. Enabling any of these policy settings gives you a choice of Hibernate, Shut down, Sleep, or Take No Action.</quote> so this might be by design? – Martin Feb 2 '11 at 7:19
@Martin: It shows the same here, so I would say that and everything troubleshooted in the question is by design. But I think I have another option you might want to look into at User Configuration > Administrative Templates > Start Menu and Taskbar > Add Logoff to the Start Menu, although it says it's for the Classic Menu it is used here on the new Start Menu UI. There is also the same setting but with Remove instead of Add so you might want to check both of them... – Tom Wijsman Feb 2 '11 at 10:18
Oh, please note that I am using R2 and based on my previous comment I've found something useful: "In Server 2008, if you use the classic start menu, you can configure it to show the log off button. In Server 2008 R2, you can select "Log off" for the power button action." from the workarounds tab here... – Tom Wijsman Feb 2 '11 at 10:22
@Tom - great, thanks. You should add the text of your 2 comments to the answer body. ... Now I only need to decide what I find more annoying: Having the classic start menu with LogOff button or the normal start menu without :-) – Martin Feb 2 '11 at 10:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .