Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not sure why, but my remote desktop connection app won't start.

Windows Event is:

Windows cannot access the file C:\Windows\System32\mstscax.dll for one of the following reasons: there is a problem with the network connection, the disk that the file is stored on, or the storage drivers installed on this computer; or the disk is missing. Windows closed the program Remote Desktop Connection because of this error.

Program: Remote Desktop Connection
File: C:\Windows\System32\mstscax.dll

The error value is listed in the Additional Data section. User Action

  1. Open the file again. This situation might be a temporary problem that corrects itself when the program runs again.
  2. If the file still cannot be accessed and
    • It is on the network, your network administrator should verify that there is not a problem with the network and that the server can be contacted.
    • It is on a removable disk, for example, a floppy disk or CD-ROM, verify that the disk is fully inserted into the computer.
  3. Check and repair the file system by running CHKDSK. To run CHKDSK, click Start, click Run, type CMD, and then click OK. At the command prompt, type CHKDSK /F, and then press ENTER.
  4. If the problem persists, restore the file from a backup copy.
  5. Determine whether other files on the same disk can be opened. If not, the disk might be damaged. If it is a hard disk, contact your administrator or computer hardware vendor for further assistance.

Additional Data

Error value: C00000B5
Disk type: 3

Any idea how to fix this?

share|improve this question
1  
And the file is there? –  Tobias Plutat Jan 26 '11 at 9:24
2  
Have you tried running the sys file checker? sfc /SCANNOW from a cmd prompt –  DMA57361 Jan 26 '11 at 13:46
add comment

1 Answer

up vote 1 down vote accepted

Try replacing the file with a good copy from another PC. If that still doesn't work try doing a full repair of the windows install, not recovery console, a full repair. This may take a little longer but will almost certainly fix the problem and you won't lose any data or settings. If you don't have another 7 PC you can install RDP 7 on a vista or xp machine and copy the dll from that pc, it is basically the same thing. My last idea would be to install your own MSTC, this is fairly easy and in fact company's like AEP's Netilla will push there own MSTSC client on you as not to interfere with the default windows one. It's a total of 5 reg keys that need to be added and 4 files. I can help you with this if need be.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.