Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to fill a form (which I received in .doc format and saved as .odt). The file is read-only except for the fields where I can enter the information. Unfortunately, with the fields filled it doesn't fit on one page, and I need to edit it so I can print and submit it.

With LibreOffice beta 3, I could edit anything outside of the fields, and the fonts were slightly smaller, so it fit on the page even with the fields filled. Today I upgraded LibreOffice, and when I opened to edit a field where I had a mistake, it no longer fits on the page, and I can't edit it. When I opened the properties it says that the document is NOT read-only, but it is. When I try to delete text it tells me that I can't edit the read-only content.

Can anyone give me some advice, because I've been trying to print my form for 2 hours already.

I tried AbiWord and KWord, but both are missing elements from the page (though the forms fit). I can also edit the margins (Format -> Page is dimmed, but when I begin to edit a field it's no longer dimmed)med

share|improve this question
    
I also encountered inconsistent handling of encryptied .doc files. So far, the only help I could find was this link. Unfortunately it requires Word. itmanager.blogs.com/notes/2005/04/how_to_crack_un.html If the script editor does not work, you might do this: 1. In Word open protected .doc 2. export to word xml 2003 format 3. edit xml file to remove protected tag 4. reopen xml in word and save .doc 5. import to Libreoffice. –  user109588 Dec 14 '11 at 19:15
add comment

4 Answers

You have to turn "Design mode On" in order to make changes on the document.

Enable the form toolbar through the option View -> Toolbars -> Form Design in the main menu, and the button for toggling design mode on/off appears.

share|improve this answer
1  
How, pray do you do that? –  aaronsnoswell Jul 10 '12 at 4:54
add comment

I was having a similar problem, trying to edit a .doc file, and activating "Design Mode On" didn't help it.

I was able to edit it only after saving it as a Word 97/2000/XP/2003 (.doc) and then doing a sequence of disabling and enabling again edit again, through clicking the button "Edit File" (in the default toolbar, sits at right of the Send Document as E-Mail).

share|improve this answer
add comment

I solved my problem here: http://prajapatinilesh.wordpress.com/2008/02/25/open-office-is-not-allowing-us-to-change-the-content/

I hope I helped.

Jackson William

share|improve this answer
1  
You should add the description of your solution to your answer rather than only posting the URL. A valid URL will always turn to a 404 after a sufficent measure of time. –  Shadok Jan 16 '13 at 16:34
add comment

Unfortunately I ended up using Word 2007 as I was unable to work out how to do this in LibreOffice.

Locked text like this can be due to Word "Forms". Copying from Unlocking Forms in Word 2007:

Go to the Quick Access Toolbar > More Commands > Commands not in the Ribbon - scroll down to Lock - add to your Quick Access Toolbar

and - amazing - the Padlock IS now available to use on a Fill-in Form just like in Word 2003 - just click to unlock and click again to re-lock your form!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.