Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a page I was sent to I read this:

"... “attack the ... â€Â hinge the hips"

What causes this? Is it a problem on the site's side (bad encoding for the character set in the html preamble), or is it on my side? Can I do anything about it?

Thanks,

JD

PS: Here is the page: http://davedraper.com/blog/2010/08/04/hip-movement-continuum/

share|improve this question
    
This can have a number of reasons. For a specific answer, a link to the page would be best –  Pekka 웃 Jan 26 '11 at 14:54
    
Fair enough - done. Thanks for the suggestion. –  JDelage Jan 26 '11 at 15:02
    
Also, information on what browser you're using, what OS, and what language(s) the OS and browser are set for. –  chris Jan 26 '11 at 15:02

1 Answer 1

up vote 2 down vote accepted

This is on the site's end. There's nothing you can do really.

The site is UTF-8 encoded. What you are seeing is most likely the result of quote characters that take up multiple bytes internally (three bytes forming the character) represented in a single-byte encoding like ISO-8859-1 (where those three bytes are displayed as three separate characters, and don't make sense.)

This also often happens when content is copy+pasted from Word.

Here is a table of common multi-byte sequences and what they meant to be (the title is german, but the content is pretty self-explanatory.)

This is it:

“   “

This happens often when the web site's developer gets the encoding wrong in some part of the process - in the input form, the database tables, or the database connection.

share|improve this answer
    
That's what I thought - thanks! –  JDelage Jan 26 '11 at 15:19
    
It's true that the problem is on the other end, but it's not always true that there's nothing you can do. It sometimes helps to change the character encoding your browser is using, which most Browsers let you customize. In Firefox, under "View", there is a "Character Encoding" menu and you can try different options. Doesn't seem to help for the one JDelage linked to, though. –  frabjous Jan 26 '11 at 18:14
    
@frabjous yup, in this case, the encodings are mixed up so badly that there is no easy way to fix it. (It's UTF-8 bytes as interpreted by a single-byte encoding but represented in UTF-8). But it's true that by setting a specific encoding in the browser, the page can sometimes be forced to display the right way. –  Pekka 웃 Jan 26 '11 at 18:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.