Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a programm (speed fan controller for acer notebook, called 1810tray.52). This tool seems to require admin rights - every time I start it the UAC asks me for permission.

Now I want to have this tool autostarted. So I've created a shorcut and put it into the autostart folder. Additionally, I've opened the properties for "1810Tray.exe" and under the tab "compatibility" I've checked the checkbox "run programm as administrator". Unfortunately, the tool is still not autostarted.

Somebody has an advice for me how to solve this? Thanks alot!

PS: Turning of UAC completely is not an option (unless I can turn it of for only this programm?)

share|improve this question
    
Untick the run as administrator on the compatibility tab, see if this solves it. –  Moab Jan 26 '11 at 19:50
add comment

2 Answers

up vote 3 down vote accepted

Running with administrator privileges on Windows 7 will require you to confirm unless you disable UAC completely. Other methods of running as admin (like with the runas command) will also require you to confirm/type in your admin password.

There is a workaround to allow certain programs, but it's quite extensive to set up. I recommend you look at the following: http://www.vista4beginners.com/Disable-UAC-for-certain-applications It's meant for Windows Vista, but should work for Windows 7 as well.

In case the link dies, the same howto is found on the below links:
http://www.techrepublic.com/blog/window-on-windows/selectively-disable-uac-for-your-trusted-vista-applications/635
http://dailyapps.net/2008/01/hack-attack-disable-uac-for-certain-applications-in-vista/
http://www.techmixer.com/disable-user-account-control-uac-for-certain-vista-application/

share|improve this answer
    
Yeah this works, just tried this. Thanks for your effort ;) –  MrKanister Jan 26 '11 at 19:59
    
@MrKanister You're welcome! Glad it worked out for you =) –  BloodPhilia Jan 26 '11 at 20:00
add comment

A simple alternative is to create a task in the Task Scheduler, to run the program at user login, with "run with highest privileges" option set.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.