Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My current generation MacBook Pro 15" (10.6.5) intermittently has problems turning the Wi-Fi (airport) on. The usual symptom happens when I:

  • Sleep the machine
  • Open from sleep
  • Wi-Fi is off (the airport signal is blank)

I click on Airport icon → Turn Airport On. But nothing happens.

One recommended solution was to delete the "Automatic" location and create a new one and enable the Wi-Fi, or I delete the "AirPort" from the location and add it back. But neither of these resolve the problem.

I also called AppleCare and they had me delete /Library/SystemConfiguration and restart, but that hasn't solved the problem. I have to reboot, which is very painful.

share|improve this question

migrated from Jan 26 '11 at 21:09

This question came from our site for system and network administrators.

I pulled a PC move and "forced" shut down (held the power button down until it the machine turned off) and BOOM, Wi-Fi was back in action after the next boot.

Not condoning this computer taboo, but it might be worth a try.

share|improve this answer

Looks like its a well known issue ( with no tried and true solution. I'm running a late 2008 unibody macbook pro with 10.6.6 and I am not seeing this problem, so have you considered the 10.6.5 -> 10.6.6 update?

share|improve this answer
Check the version numbers in your post. They don't make sense. – Daniel Beck Jan 26 '11 at 21:47
Fixed - Thanks for the pointer Daniel, it's been one of those days and one of those weeks so far. – RobM Jan 26 '11 at 22:09
Thanks for the suggestion - I'll upgrade and see what happens. – Simon Jan 27 '11 at 17:13
Upgraded this morning to 10.6.6, put it to sleep and went into the office, no airport :( – Simon Jan 27 '11 at 18:47
Well sorry to hear it. I guess it must be something specific to current model MBPs then. – RobM Jan 27 '11 at 19:19
  • Go to applications - utilities - activity monitor
  • make sure you are showing "All Processes" in the comboBox
  • type mdns in the search field
  • click the mDNSResponder process and click "Quit Process"

Don't worry, it will restart.

This should get you back up a running.

share|improve this answer
Do you have a source or explanation? DNS shouldn't affect WiFi connectivity in this way. – Daniel Beck Jun 16 '11 at 5:47
up vote 0 down vote accepted

The problem turned out to be hardware related.

The apple store sent my machine off to a shop where they replaced the motherboard and airport card and that did the trick.

share|improve this answer
Please accept your answer. Tis question was just bumped to the front page as the system considers it unanswered. – Daniel Beck Nov 6 '11 at 8:30
@DanielBeck thanks, I've accepted. – Simon Nov 7 '11 at 3:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.