Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my work PC, when I copy+paste some text between two applications, the rich-text formatting from the first application is preserved when the second receives it. For example, if I am copying from an Outlook message that contains size 10 Tahoma to a Word document which is formatted in Size 12 Arial, the pasted text will be size 10 Tahoma.

I don't want this to happen. I never want the second application to format the text to what it was at the source of the copy.

I suspect this is an OS level setting, because on my home PC, this does not happen at all.

I could configure each application to receive only plain text from pasting, but the optimal solution I believe would be disabling any RTF data in the clipboard itself. Right now my solution is to first copy to notepad to "sanitize" the clipboard text of any RTF data, then copy it to the second application. But this is somewhat tedious.

share|improve this question
    
When you copy-paste in Word, you can select text only, source format or destination format. And you can also set a default paste mode. In 2010, at least. –  Ariane Apr 13 '13 at 1:55

4 Answers 4

up vote 4 down vote accepted

Take a look at PureText. I don't think there is a specific "OS-level setting" for disabling rich text in the clipboard, but the goal of PureText is to do exactly that.

It also gives you the flexibility of setting custom hotkeys for converting text to plain text format. By changing the hotkey to Ctrl-v, you can paste and convert the text in one shot.

enter image description here

Compatible with Windows 95 and up. PureText is freeware.

share|improve this answer
    
it won't let me use ctrl+v. i'd really like it to be seamless. great suggestion though –  user13137 Jan 26 '11 at 21:44
    
Try Ctrl-C so it converts upon copying. I don't recall which one I used with puretext a while back, but I know one of those combinations will convert it at the same time. –  John T Jan 26 '11 at 21:52
    
if it's set to ctrl+c it will paste instead of copy –  user13137 Jan 26 '11 at 21:57
    
@user13137 no, just uncheck the "also perform the following actions..." which tells it to paste. –  John T Jan 26 '11 at 22:04
    
but then it doesn't copy either –  user13137 Jan 26 '11 at 22:20

Use auto hot key, put a hook on clipboadrd change, get clipboard contents to a var, clear the clipboard and then set it back to clipboard. so the RTF will be lost.

Downside - looks like wont be able to copy files too. but can switch off script when you need to do that

see http://www.autohotkey.com/docs/misc/Clipboard.htm

share|improve this answer

I use Notepad to drop all the formatting

  1. Copy (Ctrl-C) the stuff you want
  2. Open Notepad
  3. Paste (Ctrl-V) into Notepad
  4. Select all (Ctrl-A) from Notepad
  5. Paste (Ctrl-V) into destination
share|improve this answer

Press Ctrl+Alt+V in Word to Paste Special, i.e. paste without formatting.

share|improve this answer
    
i was looking for a general solution (agnostic to application receiving), but thank you –  user13137 Jan 26 '11 at 21:59
    
@user You could try to check your other applications (Word was probably a bad example :-) ). Maybe they support a similar shortcut. While not as thorough as a system-wide setting, it'd be a bit more flexible. –  Daniel Beck Jan 26 '11 at 22:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.