Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd like to use the mouse in Vim only for scrolling (not to enable other Vim modes or otherwise interact with Vim). Using :set mouse=a seems to be an all or nothing operation, can this be altered? Alternatively can iTerm be made to only pass through scroll events and never click/drag events?

Long Explanation: I use Vim in iTerm a lot and don't use the mouse. However, inertia scrolling with a trackpad is really nice and a great way to peruse large files. I can :set mouse=a and use the trackpad to scroll and it's great. Now when I click however vim enters visual mode and iTerm will not copy selected text. I would like to retain iTerms ability to select and copy text.

I have thought about setting up Vim so that copying in vim will copy in Mac OS X (using pbcopy, I need to do this anyway). This will do the trick when editing local files, but most of the time I'm ssh'd somewhere and editing remote files.

share|improve this question

4 Answers 4

up vote 18 down vote accepted

You could use

:set mouse=nicr

It works only with mouse scroll as I've tested.

share|improve this answer
1  
Not quite what I need as while it will scroll in vim, iTerm won't let me select text. I've :set mouse=i so that scroll works in insert mode and iTerm select in normal mode. Close enough, so I'm marking answered. Thanks for the idea! –  Jonah Braun Dec 15 '11 at 21:30
2  
That looks like "set the mouse to be nicer" to me. –  Kazark Aug 30 '12 at 17:07
3  
@JonahBraun, iTerm will mouse select with :set mouse=nicr if you hold down option while making the selection. See stackoverflow.com/questions/4608161/… –  John Whitley Mar 22 '13 at 23:58

I'm not sure about iTerm but this is achievable with Terminal.app.

  • Scrolling in Terminal.app:

http://ayaz.wordpress.com/2010/10/19/using-mouse-inside-vim-on-terminal-app/ (install SIMBL and MouseTerm)

  • Scrolling only:

    1. Go to terminal;
    2. Preference;
    3. 'Settings' Icon;
    4. 'Keyboard' Tab
    5. 'Mouse...' button;
    6. There under 'Send mouse events for:" uncheck "Left click", "Middle click", "Right click".

Done.

share|improve this answer

If you set mouse=a, you can still use Option-click to make iTerm do selection. Not ideal, but it's the best option I've found.

share|improve this answer

Even better than the accepted answer:

set mouse=a

This allows scrolling and then highlighting gives you a visual block.

share|improve this answer
1  
This enables things other than scrolling. –  Kazark Aug 30 '12 at 17:10
1  
Moreover, that is already mentioned in the question. –  Kazark Aug 30 '12 at 17:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.