Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on a MacBook Pro and suddenly lost access to the internet. Skype works fine, but neither Safari nor Chrome do. Other computers on the network are fine and I can ping 4.2.2.1 but not google.com. Changing my DNS server to 4.2.2.1 doesn't solve the problem and I've tried switching between wifi and a regular wired connection.

I live in China and had been using a WiTopia VPN service through the open source TunnelBlick client earlier in the day. I left to go have lunch, shut the laptop, and when I came back and opened it it could no longer reach the server, nor could the browser get online.

I really can't restart, because I'll lose really important work. Any ideas/help would be greatly appreciated. Thanks!

Update: I've tried entering googles IP address into Chrome and it loads just fine so its clearly just a DNS issue of some sort.

share|improve this question
    
Erm. Is the concept of saving your work, and then rebooting really not an option? –  Diago Jan 27 '11 at 10:56

3 Answers 3

Open /Applications/System Preferences and go to Network, select your network connection, click Advanced, DNS, and enter another DNS server.

8.8.8.8 is Google's DNS. enter image description here


You can also try flushing the DNS resolver cache by opening /Applications/Utilities/Terminal and entering the following:

dscacheutil -flushcache
share|improve this answer
    
+1 for dscacheutil. Taught me something new. –  user3463 Jan 27 '11 at 22:26

Hi
It sound like its a dns issue because you mention that the ip is good
but names doesnt work for you.
Try going to the ip configuration and write a different dns.
Thanks

share|improve this answer
    
I've done this but its somehow deeper than that.. –  Jack Jan 27 '11 at 10:40

Apparently Witopia modifed the network settings and didn't restore them. You can restore them to the way they were before you used Witopia (without restarting the computer) by disconnecting the network, then reconnecting it:

Either

  • Turn Airport off and then back on; or
  • Unplug the Ethernet cable, then plug it back in.

That will reset the network, which usually solves problems like this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.