Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there any way to speed up GIMP's startup time on Windows Vista Home Premium 32-Bit 1.6 [Dual] Intel Processors? On XP [different computer], it loads in less than 3 seconds. On Vista, it takes 20 seconds:

  • 2 Seconds (other - fonts, brushes, etc)
  • 18 Seconds (extension-script-fu)

It just freezes at extension-script-fu. Looking at Process Explorer, I see that it's not taking any CPU at all. EDIT 1: It does seem to be taking 50% of the CPU.

It gets stuck for about 18 seconds, and then starts working again. Then, the actual GIMP program pops up [...finally]. I have the latest stable version running (I think). I tried it with XP SP2 Compatibiliy mode and/or Run As Administrator, but that didn't help.

EDIT 2: One way would be to disable script-fu. Does anyone know how to disable it at startup? Is it possible? Would GIMP still work? What wouldn't work? Could I start it later, after loading?


EDIT 3: Seems to startup at lightning speeds even with script-fu (<3 seconds) in GIMP 2.8 RC1 on Windows Vista.

share|improve this question
    
It takes about 20 or more seconds to run on my PC, and it's WinXP SP3. Not real happy about that either. –  Steve Jan 28 '11 at 8:13
1  
@Steve They really should fix it. But of course, when I asked at a GIMP forum once, they started telling me how impatient I was... They said they'd be happy if it took even 2 minutes to load! (Probably because they have nothing else to do.) –  muntoo Jan 29 '11 at 4:57
    
As far as I know, the only real way to speed up gimp startup, is having a very fast pc. On my core i5, it loads about 3secs. –  Michael K Feb 16 '11 at 9:50
    
@Michael The problem is that the GIMP process stops using CPU for 18 seconds. So, it's not really a problem with how fast my PC is (Intel Core 2 Duo @ 1.8Ghz/processor), or how much RAM it's got (2GB, have my Vista lean and mean, removed unnecessary services/security risks, disabled Aero, etc; Also, I have ReadyBoost with a Kingston DataTraveller USB 2.0 with 4GB of space.) –  muntoo Feb 18 '11 at 0:35
1  
@muntoo: the majority of program load times (not just GIMP) is not spent on the CPU, the majority of program loading time is spent reading from harddisk. A harddisk read speed highly depends on how fragmented the drive is, sequential reading typically can reach 40MB/s, but highly random reads can kill performance reaching below 1MB/s. A program that needs to load 100 MB of data can be loaded in 2-3 secs if the read is mainly sequential, but it can take more than 20 secs if the files are scattered about. –  Lie Ryan Sep 4 '11 at 19:10

6 Answers 6

up vote 8 down vote accepted
+50

If this happens to you when the splash screen gets to "Loading Data Files - Fonts", then there are several workarounds to this slowdown.

To analyze the slowdown, you may add the --verbose parameter to GIMP to better analyze startup problems.


The article Slow GIMP startup : Graphics advises :

This used to happen to me too. Some kind-soul told me that there in the c:\documents and settings\user-name\ directory, there will be a ..fonts-cache1 file. Delete that cache and re-start GIMP. First time it takes a while to make that fonts-cache again, but from 2nd time it should be pretty normal.


Another advise is :

I created a shortcut with the command parameter --no-fonts and it started very quickly.


The GIMP FAQ says :

The GIMP takes too long to load - how can I speed it up?

The main things are to make sure you are running at least version 1.0, and make sure you compiled with optimization on, debugging turned off, and the shared memory and X shared memory options tuned on.

Or, buy a faster system with more memory. 8^)

If it's still too slow for you, the easiest speedup is to invoke the GIMP with the "--no-data" option. This prevents the GIMP from loading patterns, brushes, and similar resources when it starts. You may benefit slightly from the "--no-splash" option as well; you might want to time that one to see if it really helps enough to be worthwhile.


If the problem lies in one or more extensions, the only solution is to uninstall these extensions. The extensions are found in the folder GIMP is installed in (usually Program Files), inside C:\Program Files\GIMP-2.0\lib\gimp\<version>\plug-ins. Just rename the extension file to .old or something, for example script-fu.exe to script-fu.exe.old. The easiest way to get rid of all the extensions is to rename the entire plug-ins folder.

share|improve this answer
    
I tried them, but they don't help. (And advice #1 is not applicable - no such file exists.) –  muntoo Feb 17 '11 at 0:12
    
What stage in the startup process takes the longest time? –  harrymc Feb 17 '11 at 7:05
    
Note: I have GIMP and I have found the file C:\Users\<myself>\.fonts.cache-1. It is rather large and not even hidden. –  harrymc Feb 17 '11 at 9:07
2  
@harrymc Renaming it works - 5 seconds. :) When I try running script-fu.exe (just for fun), I get: "script-fu.exe - Unable To Locate Component --------------------------- This application has failed to start because libgimpui-2.0-0.dll was not found. Re-installing the application may fix this problem." Not sure if it means anything, just sayin'. –  muntoo Feb 22 '11 at 6:50
1  
script-fu is probably launched from The GIMP with a certain environment that you don't have. Now that you know the exact cause, you could maybe start a discussion on their forums, so maybe the problem will be fixed with a future version. –  harrymc Feb 22 '11 at 7:01

Font processing is often a cause of slow Gimp startup. There seem to be many sources of the problem, and suggested solutions may not work. In Gimp 2.6 on Windows, I found that the "--no-fonts" command line parameter did work (saving 50 sec), but (1) you then cannot add text to an image, and (2) you have to pre-start Gimp rather than just clicking on an image.

An odd but effective solution I found was to go to Edit-->Preferences-->Folders-->Fonts and delete the entry there (normally ".gimp-2.6\fonts"). This has the effect (for unobvious reasons) of eliminating the font startup delay but still allowing text usage on images using all the fonts installed in Windows.

share|improve this answer

I copied all files in C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins to a new folder named Unused, also inside plug-ins.

Started up Gimp: ~1 second compared to ~40 seconds previously. I then copied frequently used ".exes" into the plug-ins folder. Now Gimp starts in ~3 seconds.

share|improve this answer
    
Welcome to Super User! But... don't you see the preview, or the result? And why need those arrows anyway? @Martin did a good job, but that still looked horrible on mobile. And it's still useless to add the arrows. Please see also Other people can edit my posts?! Thanks. –  Arjan May 19 '13 at 11:11

The issue is quite likely your brushes or plugins. For example, GIMP loads all brushes into memory as it's starting up. On my own system, this consumes roughly 1.1 GB of RAM, and it does this before loading the splash screen image (the splash screen window is there, but with a blank white background). Once the program has finished consuming 1.1 GB of RAM, the image appears and it loads up rather quickly. If I delete my brushes, the program starts up in about 4 seconds and consumes only 49 MB of RAM.

Edit: Windows 7 64-bit, Pentium Dual-Core 2.7 GHz, 4GB RAM. GIMP 2.8 from Partha's Place.

share|improve this answer
3  
That is a lot of brushes then –  Simon Sheehan May 21 '12 at 3:43

Gimp takes around 10 seconds to start here, on a approx 2 GHz Xeon, Arch Linux. This tells me it's most likely to be a problem with the Windows-version of Gimp. Also, I've experienced myself that the Windows-version of Gimp takes a long time to load.

To answer your question, you could run Linux. I bet Gimp would even start up faster if you run Gimp in Linux in a virtual machine (like VirtualBox).

share|improve this answer
2  
I'd rather not have to switch to VirtualBox and run Ubuntu each time I want GIMP... Thanks anyways. –  muntoo Feb 19 '11 at 2:33

In my experience Windows Vista is notoriously slow with less than 4 GBs of RAM (and you mentioned that you have 2 GBs). Switching to Windows XP improves things greatly but the drivers aren't always available with newer hardware so the next best option is to go for Windows 7 (which also seems to need a lot of RAM, unlike XP).

I have also noticed on some computers that the Disk Defragmentation schedule doesn't run in Vista despite being scheduled to run weekly, so you may wish to try running this manually -- the "Disk Defragmenter" should be in your Start Menu under "Accessories" -> "System Tools." After running this twice, I find that things speed up considerably (although it never seems to be as good as new).

An in-depth comparison of various Disk Defragmentation tools can be found here, by a Mr. Roedy Green who is amazingly detailed and has a very high level of technical expertise, but also is very good at explaining things in an easy-to-understand fashion: http://mindprod.com/jgloss/defragger.html

Disk Defragmentation is probably your best bet if you can't switch to a better OS.

share|improve this answer
    
I use Auslogics DiskDefrag + Defraggler, and as I've said in the comments below, I've gotten my Vista tweaked as hard as possible while still looking prettier than XP (disabling Aero). I've heard of Vistas where GIMP comes on fast (3 seconds), and on XP it doesn't. On "my" XP (laptop), it comes on fast, on Vista, it doesn't... BTW, my machine is better than when it came all "new" and "shiny". –  muntoo Feb 18 '11 at 5:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.