Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a simple issue that I can't fix. When I try to color an area the color goes out of the borders and creates ugly edges.

Instead of getting a picture like this:

enter image description here

I'm getting a picture like this:

enter image description here

How can I fix this?

share|improve this question

2 Answers 2

You surely have a selection loaded (hit ctrl + h to see if it is hidden) with a large feather or tolerance value. Just hit ctrl+d to deselect. Or you are using some layer mask, or applying some filter, or maybe you have some "layer efect" on the layer (create a new layer and ensure that you are not creating a layer effect in the proccess. Do it in that new layer.) .

With more info on the procedure I could give more clues...

share|improve this answer
    
well I created a new layer and selected a square area and filled it with the blue color but it still giving this effect, also I tried the gradient and the bucket tool, they give the same result, also I tried resetting all settings to defaults, Can you tell me what options should I edit to fix this effect and make the color stick to the square ? –  Peter Jan 28 '11 at 10:11
    
Are you sure there's no layers above it ? Which software are you using, Photoshop? –  S.gfx Jan 28 '11 at 10:16
    
yes I'm using photoshop CS2 and yes I'm sure there's no layer above it, first I created a new white document, then colored the background, and then created a new layer and used the rectangular marquee tool to select a square 300 x 300 pixels and here is my problem, can't fill the square to obtain a picture like this www.flickr.com/photos/58847495@N05/5394768997/ also this is a fresh install of photoshop never used it before. and thank you very much for your help :D –  Peter Jan 28 '11 at 10:21
    
Can only think of you'd post the psd (in case that'd be possible) , but another idea is that maybe your marquee settings have been changed...But...Tolerance setting does not produce that... How are you filling the marquee? try doing with hitting shift + f5, not the bucket tool...Running out of ideas.... ;) –  S.gfx Jan 31 '11 at 8:41

You have to change your feather setting. Make sure you are on the marquee tool (m) and make sure the feather is set to 0.

Not sure where that is in CS2. In CS4 it's in the main toolbar at the top.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.