Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to send/receive my Yahoo mail with a desktop mail program (Thunderbird). Mail receiving is working fine, but not mail sending. My e-mail address is don@yahoo.co.uk and the settings I'm using are:

enter image description here

Can someone verify whether these are the correct mail-sending (SMTP) settings for Yahoo?

share|improve this question
add comment

3 Answers

There are two methods for using SSL/TLS with SMTP (and other protocols): implicit and explicit ("STARTTLS").

You have configured Thunderbird to use "SSL/TLS", which is implicit SSL, but you have pointed it to smtp.mail.yahoo.co.uk port 587, with which the server expects SSL to be activated explicitly.

  • Either keep the port 587 change Connection Security to "STARTTLS",
  • or change the port to 465 and set Connection Security to "SSL/TLS".
share|improve this answer
add comment

Yahoo POP3 and SMTP Settings: Find below the basic POP3 settings that you need to configure in the email program where you want to access Yahoo mails.

Incoming Mail (POP3) Server: pop.mail.yahoo.co.uk
Outgoing Mail (SMTP) Server: smtp.mail.yahoo.co.uk (use authentication, optionally use port 587)
Account Name/Login Name: Your Yahoo! Mail ID (your email address without the "@yahoo.com")
Email Address: Your Yahoo! Mail address (e.g. user@yahoo.co.uk)
Password: Your Yahoo! Mail password

Read more: http://techblissonline.com/yahoo-pop3-and-smtp-settings/#ixzz1CKFD6Su8

Looks like you've got the wrong port for your outgoing mail - Use 465 instead.

In response to your comment: Updated the content.
Looking at the wording, have you tried that port without authentication, or the efault port with authentication. The optional seems to suggest one or the other.

share|improve this answer
    
I think the servers are different for @yahoo.co.uk addresses help.yahoo.com/l/uk/yahoo/mail/yahoomail/pop/pop-114.html –  Dónal Jan 28 '11 at 11:26
add comment

Another option to consider is that your ISP may be blocking your outbound email. Many ISPs (including my own which is AT&T) block connections to any smtp server other than their own. They use this as a measure to block potential spammers among their clients so they can monitor outbound mail from their network. You should check with your ISP's help docs to see if this is their policy. If so, they should have information on how to set up your outbound mail to make this function.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.