Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Synergy server on a Windows 7 box, and a Mac client connected to it. Most keys work fine, except for the Shift key on the right side. The left Shift key works just fine but not the one on the right side.

Does anybody have the same issue, and what is the resolution?

share|improve this question

migrated from serverfault.com Jan 28 '11 at 17:51

This question came from our site for professional system and network administrators.

add comment

5 Answers 5

up vote 3 down vote accepted

I can confirm that downgrading a windows 7 server to 1.3.4 fixes the problem. On the Windows 7 server I tried every server up through 1.4.2 beta and none of them fixed the problem. On OSX 10.6 client I tried everything up through the 1.4.2 beta and none of the newer versions solved the problem.

share|improve this answer
add comment

I was struggling with the issue at work until my good friend Paul Udruscu pointed out that I can use KeyTweek on Windows, to remap the right shift key to the left one and alleviate the issue altogether.

share|improve this answer
    
Good workaround, i'm using it with 1.4.6 Beta on all nodes –  Haytham Elkhoja May 5 '12 at 12:44
    
This worked perfectly for me as well. Saves me from having to downgrade to the 1.3.8 version of Synergy which is a significant downgrade. –  BlueVoid Jul 9 '12 at 17:29
add comment

This is logged in the synergy bug list here: http://synergy-foss.org/pm/issues/2842 so yes, lots of people have the same issue.

They don't seem to come closer to fixing this however.

share|improve this answer
    
Still broken as of May 2012 :-/ –  Rob Osborne May 16 '12 at 18:21
add comment

Going off the workaround above by Ash, this can also be accomplished by adding a registry value to Keyboard Layout. It remaps the left shift key to the right shift key.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout
New binary value
Name: Scancode Map
Value: 00 00 00 00 00 00 00 00 02 00 00 00 2a 00 36 00 00 00 00 00

Reference: modified this example; worked on Windows 7 with Synergy 1.4.8.

share|improve this answer
    
This works great. Note that it requires a reboot after you make the registry key. –  radicand Jun 29 '12 at 15:48
add comment

Are you running 1.3.6 by any chance? I just ran into the same problem between a Windows 7 server and Mac OS 10.6 client, exactly as you describe.

I installed the 1.3.7 nightly build (902 specifically) from http://synergy-foss.org/packages/ on both ends, and the problem appears to be fixed.

Edit: scratch that, the problem is back. Going to try a few more things...

share|improve this answer
    
I downgraded my server back to 1.3.4 and that solved the problem. Client on Mac is fine as 1.3.6. –  Haoest Feb 2 '11 at 19:56
    
Yup, taking the server back to 1.3.4 fixed it. I tried going all the way forward to 1.5 nightly, but no dice. Thanks! –  Lem Feb 2 '11 at 20:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.