Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a command line program that has somehow got set to run in full screen mode. I want to make it run in a window instead. How do I do this?

The details probably aren't relevant, but it's the Visual Basic compiler, a part of Visual Studio 2005. Whenever I compile a program in VS it runs the compiler, which loads very briefly as a fullscreen program. The flickering effect of having the screen go black everytime I compile is really annoying!

When I run the program from Windows Explorer by double-clicking it appears as fullscreen but then terminates before I can interact with it. Is there a non-interactive way to change it to windowed mode?

Thanks.

share|improve this question
    
Sidenote: It's not actually me who's having the problem, it's my co-worker. I wrote the question in first-person, though, as it's easier to read than "My friend has this problem with his computer..." –  Cosmic Flame Jan 28 '11 at 18:34
add comment

1 Answer 1

up vote 2 down vote accepted

Windows Console settings are kept in Registry (Start → Run → regedit), under the HKEY_CURRENT_USER\Console key1.

  • The default settings are under HKCU\Console itself. Make sure the FullScreen value is set to 0. If not, change it.
  • Per-program settings are stored in sub-keys named according to the program's path. Look for an entry belonging to your compiler, fix it if necessary.
  • You can just delete the entire HKEY_CURRENT_USER\console key (although you will lose the customizations you might have wanted to keep).

A trick you could try:

Start a long compile, and just after the full-screen switch press Pause on your keyboard to pause it, then Alt+Esc to minimize the window. Right-click on its button in the taskbar, choose Properties, then Options, and select Display Options → Window.


1 In regedit, keys are the folders in the left-side tree, and values are items in the right-side list.

share|improve this answer
    
Regedit worked perfectly, thanks! –  Cosmic Flame Jan 31 '11 at 9:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.