Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In the new Windows Live Messenger there's a link nanny built in. I.e. When you click links it sends you first to a page "You are now leaving Live Messenger" etc... designed to help protect people who don't know better from following fishy (or phishy :D) links sent to them.

This is really annoying for me as a user who generally knows what I'm doing, I can spot a fishy link, or just know well enough not to open links I don't know about.

But when I'm collaborating with a colleague and we're passing pastebin.com urls back and forth it's incredibly annoying to have to do this EVERY TIME.

Is there a way to turn this feature off. Where's the "I'm not an idiot" setting in Live Messenger?

What's more is this feature doesn't even really protect you, it doesn't look ahead to the site you're going to, checking if it's on a blacklist or known to be dangerous. It just makes you have to click once more to go where you want to go.

share|improve this question
up vote 2 down vote accepted

There's no way to disable it but there are workarounds. If you use IE you could try turning SmartScreen off in the security menu.

Here's a Chrome extension you can use

Here's a GreaseMonkey script you can use for Firefox

share|improve this answer
    
Oh god thank you :) – Aren B Jan 28 '11 at 21:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .