Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

my old HDD was dying and it seems somehow it screwed some drivers in the process. Suddenly I'm getting "You need to format the disk in drive x: before you can use it" whenever I plug ANY usb disk (and they all work on other systems, so no, no problems with drives; even kindle dows not work).

I've managed to "repair" the bad sectors with seatools and duplicate the disk (using linux dd) on a new one (same model).

Everything seems to work ok, just this bliping error. I've tried google but I see many threads with this problems and no solution.

Ideas?

Update: NTFS external drive does work, but none of the fat do. So I guess my fat driver is broken. Which dll do I need to replace?

share|improve this question

migrated from serverfault.com Jan 28 '11 at 21:54

This question came from our site for system and network administrators.

Try:

  • Start->All Programs->Accessories->Right click Command Prompt, Run As Admin
  • sfc /scannow
  • wait (it has a nice little progress bar, but it takes forever)
share|improve this answer
    
Thanks, didn't know about this! – Paul Jan 28 '11 at 20:45
    
And it worked! Thanks a million! – Paul Jan 28 '11 at 21:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.