Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Firefox allows you to force webpages to use the fonts you specify by unchecking "Allow pages to choose their own fonts instead of my selection above" in the advanced fonts settings. I use this to force cleartype fonts in Firefox.

Is there a way to do this in Google Chrome?

share|improve this question
    
I found an extension that allows the replacement of a handful of sans-serif fonts chrome.google.com/webstore/detail/… . It's primarily for font snobs, but allows you to choose a custom font (e.g. Calibri) to use instead of Arial. Unfortunately it doesn't allow you to replace Times New Roman or Courier New. –  csnullptr Mar 27 '11 at 18:57
add comment

5 Answers

up vote 7 down vote accepted

There is an enhancement-request bug report open at Chromium's Google Code bug tracker to enable ClearType support. It's a priority 2 so it will hopefully be fixed a few releases from now (but maybe that's just wishful thinking).

share|improve this answer
    
Bummer, I was hoping there was a hidden config for this already. I'll leave the question open a little while longer in case someone has any other suggestions. –  csnullptr Jan 30 '11 at 0:13
    
"a few releases from now" is unfortunately (as you rightly surmise) absolute nonsense. That bug report's been sitting there from 2008 :( –  Mahmoud Al-Qudsi Apr 30 '12 at 3:00
    
Actually, Chrome now respects the system setting. See bug 96393. –  squircle May 1 '12 at 15:22
add comment

Windows XP clear type is enough for Chrome. Just turn on Display->Appearance->Effects->"Use the following method to smooth edges of screen fonts"->"Clear Type" and you are done.

share|improve this answer
    
I do have cleartype enabled. I was asking about forcing webpages to use fonts with cleartype hinting if possible (e.g. Cabrili, Cambria, Consolas). The cleartype fonts as they're usually referred to are much easier to read, in my opinion, than the default fonts that websites usually specify (i.e. Arial or Times New Roman). –  csnullptr Feb 8 '11 at 3:20
add comment

Bumped into this when I was also searching for how to force chrome to use my fonts. Found Ubuntu 10.10 (unified font style) v1.0 It forces chrome to use Ubuntu fonts. But can not select other than Ubuntu fonts.

share|improve this answer
add comment

See solution (Comment 22 by mackst...@gmail.com, Jan 5, 2011)

  • Go to about:flags
  • Click Enable in the "Tabbed Settings" section
  • Scroll to the bottom and click Restart
  • Go to wrench -> Preferences -> Under the Hood -> Web Content -> Change font settings -> Minimum Font Size.

This forces pages to use the minimum size specified. You may also specify font default types to be used (Standard, Serif, Sans-Serif, and Fixed-Width). I am running chrome 19.0.1084.56, and this works for me.

If you see a discrepancy with the provided information above, please, don't hesitate to contact me and correct my understanding of the facts. Always happy to learn more :D.

share|improve this answer
1  
And this relates to the original question on how to enable ClearType how exactly? –  rustyx Aug 26 '12 at 15:00
add comment

You can specify which font you want Chrome to display, follow the steps below.

  1. Go to the directory: C:\Users\*username*\AppData\Local\Google\Chrome\User Data\Default\User StyleSheets
  2. Open "Custom.css" using Notepad (The file will be blank if you didn't add anything inside).
  3. Type this line of code in:

    -* {font-family: "font name";}

  4. Don't type the hyphen (-) in, this is added so as to make the asterisk (*) display, instead of bullet point.
  5. Replace the "font name" with your own font, this is just an example.
  6. Save the file, and launch Chrome.
This will make Chrome's default font become the font you want it to display, also applies to webpages, but some website developers would probably do something that it won't force ALL content to be displayed in your desired font. To fix this, follow the steps below.

  1. Once you added the code and saved the CSS files from the above steps, open the CSS file again.
  2. This time, add in any rubbish characters, for example, a hash (#) can do the trick. Example code:

    -* {font-family: "Segoe UI#";}

  3. Now launch Chrome. Go to Settings by typing "chrome://settings" without quotes to access Settings menu (or press the icon with 3 lines and click Settings)
  4. In the "Search settings" field, type "fonts" without quotes and click Customize fonts...
  5. Under "Standard Font", choose the fonts in the list and Chrome will display it.
Again, don't type the hyphen in Step 2.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.