Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am unable to launch any program on Vista, but they launch fine with Autohotkey or Launchy. Also from a cmd if I launch it with admin. Any clue?

share|improve this question
    
What error message do you get if you try to launch a program? –  James T Jan 29 '11 at 8:33

1 Answer 1

up vote 1 down vote accepted

My thought process is this:

If no programs run, then some setting probably changed that affects all files that end in .exe. It would be interesting to see if programs that run in .msc still work. This type of thing does not usually happen by random chance. There is probably hacker somewhere on the other side of the world with an evil laugh enjoying your predicament. In addition to these random changes in settings that prevent programs from running, you very likely have viruses that are responsible for putting those changes into effect in the first place. Since you are unable to run any programs, you will have to boot a live-cd and load up some antivirus software to scan the drive with. I sometimes use avg (free linux edition). Unfortunately, even once the viruses are gone, there will probably still be a bunch of settings changed specifically to make your life miserable.

You can try to get rid of the viruses and then try the instructions in the link below again with no guarantee of success. A quicker and more sure fire way to solve all your problems would probably be to back up all your files to an external hard drive. You can use a live cd like knoppix to help you with that if you like. Then re-install windows.

http://support.microsoft.com/kb/555067

1. Click Start, and then click Run. 


2. Type "command.com" , and then press Enter. (A DOS window opens.) 


3. Type the following:

         "cd\"

         "cd \windows"

    Press Enter after typing each one.

4. Type copy "regedit.exe regedit.com" and then press Enter.

5. Type "start regedit.com" and then press Enter. 

6. Navigate to and select the key:

    HKEY_CLASSES_ROOT\exefile\shell\open\command

7. In the right pane, double-click the (Default) value.

8. Delete the current value data, and then type:

     "%1" %*

 Tip: Type the characters: quote-percent-one-quote-space-percent-asterisk.

9. Close Regedit utility.
share|improve this answer
    
Thanks, but it didn't help! –  fastcodejava Jan 29 '11 at 8:10
    
Can you provide a summary of the link in your answer. Naked links aren't particularly useful. –  ChrisF Jan 29 '11 at 11:14
    
@ChrisF as you wish (-: –  James T Jan 29 '11 at 12:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.