Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using sudo until now. After an upgrade to 10.6.6, now sudo gives me incorrect password. My user has admin rights, and i can execute admin functions from the GUI (such as System Prefs, updating software etc). However, within Terminal, sudo has stopped accepting the password.

I have repaired permissions and restarted.

Some pointers ask me to use Directory Utility, but in this version it does not have a "set root user" option. I downloaded ServerAdminTool 10.5.7 but this does not work on my system. Some say to add myself to "wheel" group, but i need sudo for that. Some say if i am in admin group, i should be able to sudo, but this is not happening.

(Using OS X Snow Leopard 10.6.6, earlier 10.5.8)

MODERATOR: please delete this question. The issue had to do with Textpander expanding the password resulting in sudo failing. Not an OS upgrade issue.

share|improve this question
    
What do you mean by "stopped accepting the password"? Does it say your password is wrong? Or that you have no sudo permissions? –  Daniel Beck Jan 29 '11 at 8:14
    
It says "incorrect password" when i enter it. The keyboard is not the issue since i am able to use the same password in GUI programs such as System Priveleges. –  rahulk Jan 29 '11 at 14:15
add comment

2 Answers

up vote 0 down vote accepted

Create an new user account in System Preferences » Accounts and perform all needed administrative action to restore your sudo ability there.


Make sure you don't have a different keyboard layout in Terminal. Type your password in clear text at the command prompt.

share|improve this answer
    
On my system, I am not a member of wheel, only root is. Administrative users are members of admin though. –  Daniel Beck Jan 29 '11 at 8:12
    
My apologies. The person who did the upgrade also installed Textpander (and removed Typeitforme). My password was getting expanded in Terminal (but not in the GUI edit boxes). Thanks for your suggestion of typing in the edit box. I've disabled Textpander and now it works. MOD: please delete question. –  rahulk Jan 29 '11 at 14:24
add comment

I know this is not a direct solution, but you can try to:

  • Reboot and hold the /CMD + S key after the chime
  • In the commandline, type mount -uw /
  • Delete the file that Apple uses to check whether you have configured your mac by typing rm /var/db/.AppleSetupDone
  • Turn off the computer with shutdown -h now

Now when you boot up, you will be able to create another user that has administrative (and hopefully sudo) privileges. With this one you could e.g. reset the password of your old user account or add it to the wheel group.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.