Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just started messing around with cygwin. I've noticed when use the tab auto-complete feature for commands it always adds a '.exe' even though one isn't needed to run the command.

Is there a way to hide the '.exe' part of the bash commands?

Thanks!

share|improve this question
add comment

1 Answer

The tab auto-complete feature simply prints the name of the file.

If the file is named grep.exe, then that is what will print.

Possibly a better option than tab auto-complete would be Control-R

$ grep -r Steven *

(reverse-i-search)`S': grep -r Steven *

steven.mlodzianoski.com/post/10784353754/control-r

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.