Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm talking about this:

Preferences - Language & Text

I'd like "Romanian - Standard" to be just "Romanian". There's already an entry called Romanian, but I can't use it with my keyboard layout.

Does anyone know a way, even hackish, to accomplish this?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The system-supplied keyboard layouts are located in /System/Library/Keyboard Layouts/AppleKeyBoardLayouts.bundle.

Right-click that bundle and select Show Package Contents.

Navigate to Contents/Resources/English.lproj/


Edit the InfoPlist.strings file to change the names used for the keyboard layouts in your English locale. The left side is the internal name of the layout -- don't change that -- and the right side is the localized name.

"Romanian" = "Romanian";
"Romanian-Standard" = "Romanian - Standard";

I changed it to the following:

"Romanian" = "Romanian - Nonstandard";
"Romanian-Standard" = "Romanian";

To be able to edit these files, you need to add your user account to the list of authorized users in the English.lproj folder's Get Info dialog (read/write permissions), as well as the InfoPlist.strings file itself (also read/write privileges).

Save, close, and check System Preferences to see if it worked.

It did for me:

enter image description here

share|improve this answer
    
Thanks a lot Daniel! It worked like a charm. –  Ionuț G. Stan Jan 29 '11 at 21:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.