Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having a huge problem that my windows 7 is not loading.

I had uninstalled my bluetooth driver and then tried to reinstall it. The problem started then that all the folders from libraries vanished and windows explorer tab did'nt work.

So I restarted my computer and then got this error The boot selection failed because required device is inaccessible

I tried system repair from windows dvd but it could'nt correct the error.After repairing stopped I got blue screen showing fatal error with code c000021a and message STOP . However after some time the message has reverted back to the previous one of boot device."

As an aside I have dual booting with ubuntu installed and ubuntu is working absolutely fine.

When I try to load windows in safe boot it shows that it tries to load some driver file and then gives the above mentioned error....

I have dell inspiron laptop and have done all the memory diagnostics inbuilt which are shown as having been passed.

How can I try to make windows work.....Please help and do tell if any other information is required...

share|improve this question
    
I have later found out that this is an issue with the bluetooth driver given by dell on their download page.... As soon as you try to update or uninstall it , it begins to delete everything from your system drive... –  user57162 Oct 24 '11 at 19:22

3 Answers 3

Use a W7 installation DVD, boot from it and try a System Restore, pick a date before the boot problem started.

http://www.bleepingcomputer.com/tutorials/tutorial142.html

share|improve this answer

STATUS_SYSTEM_PROCESS_TERMINATED occurs when a user-mode subsystem, such as WinLogon or the Client Server Run-Time Subsystem (CSRSS), has been fatally compromised and security can no longer be guaranteed. In response, the operating system switches to kernel mode. Microsoft Windows cannot run without WinLogon or CSRSS. Therefore, this is one of the few cases where the failure of a user-mode service can shut down the system.

Mismatched system files can also cause this error. This can occur if you have restored your hard disk from a backup. Some backup programs might skip restoring system files that they determine are in use.

can be resolved by:

If the error occurs during system startup, restart your computer, and press F8 at the character-based menu that displays the operating system choices. At the resulting Windows Advanced Options menu, choose the Last Known Good Configuration option. This option is most effective when only one driver or service is added at a time.

If this does not resolve the error, try manually removing the offending software. If the system partition is formatted with file allocation table (FAT), use an MS-DOS startup disk to gain access to the computer's hard disk. If the system partition is formatted with NTFS file system, you might be able to use Safe Mode to rename or delete the faulty software.

If the faulty software is used as part of the system startup process in Safe Mode, you need to start the computer using the Recovery Console in order to access the file. If a newly installed piece if hardware is suspected, remove it to see if this resolves the issue.

Try running the Recovery Environment and allow the system to repair any errors that it detects.

share|improve this answer
    
Hey ... Thanks for the reply but I have read this and unfortunately none of it is helping..... How to manually remove any software when windows does'nt load.... Trying safe boot too does'nt work as I said.... And as I said that no recovery is being made using startup repair..... Thanks a lot but for your reply... –  user57162 Jan 29 '11 at 17:58
    
Then I would suggest a live CD or in the worst case a repair or reinstall, it seems very broke. Who knows your disk might be failing... –  Tom Wijsman Jan 29 '11 at 18:00
    
But at the same time ubuntu is running fine..... Also if i reinstall is there any way to gt ubuntu grub back –  user57162 Jan 29 '11 at 18:01
    
@user57162: I saw your other question, no need to mix them. If you just reinstalled Windows 7 I guess it is no problem to reinstall it once again, try to get the latest stable Bluetooth drivers this time and install them after you installed other things and perhaps made a back-up... –  Tom Wijsman Jan 29 '11 at 18:07

SOLVED! STOP 0xC000021A

Yes, you can actually access Registry on an unbootable PC. Some of these tips have worked for some users in the same situation. Worked for me on Vista, quite possibly work on Windows 7 and 8. In a hurry? Skip straight to the bolded solution.

Hi folks

Windows (Vista) was unable to start in all modes available: Safe mode, Last known Good Configuration, Repair your computer, System Restore, etc.

Since the machine was useless I went to another computer and burned the Hiren's Boot DVD v 15.2 Restored Edition. Owing to the DVD's network capabilities I updated and ran its several antivirus programs (Clamwin, Kaspersky, SuperAntiSpyware, etc) which removed a few pests. This is always a good practise before starting repairing a failed computer.

I was now ready to tackle the STOP 0xC000021A. As suggested somewhere I thought I could simply keep disabling Vista's endless [possibly-corrupted] drivers and services using MSDaRT CD (aka) ERD Commander 6. Disabling stuff however caused only more BSODs. (By the way, on my experience, MSDaRT contains the only working offline Registry editor if you'll ever need one. Hiren's editors did not work for me)

I was adamant if I ever get this Vista to start even once I'll be sure to upgrade to Windows 7 immediately.

I ran memory tests, replaced the videocard and disabled all that I could in BIOS. It did not help.

Here's a good tip - that didn't work for me: SFC /SCANNOW /OFFBOOTDIR=C:\ /OFFWINDIR=C:\Windows couldn't start due to pending tasks, although the famous c:\windows\winsxs\pending.xml didn't even exist. Modifying pending entries in Registry http://technet.microsoft.com/en-us/library/cc164360(v=exchg.80).aspx did not help either.

Here's probably even better tip: dism.exe /image:C:\ /cleanup-image /revertpendingactions (to remove pending tasks) but is included only on Windows 7 DVD and not on Vista DVD. Tried but it did not work in Vista.

Others have replaced Winlogon.exe, Csrss.exe, win32k.sys but it did not help me.

I finally solved this. I did what I should have done the first day: To reinstate earlier - still working Registry hive/hives from the days the STOP 0xC000021 BSOD didn't yet exist. I read somewhere that I do not want to reinstate all of them at once but instead try one-by-one until the issue resolves. And that actually resolved it for me: Ok, so I first copied one file called SYSTEM from C:\Windows\System32\config\RegBack to C:\Windows\System32\config overwriting the previous one and rebooted. (First of course made backup copies of both SYSTEM files, just in case). It did not help. I then copied SYSTEM and COMPONENTS. It did not help. I copied SYSTEM and COMPONENTS and SOFTWARE and the problem was solved - in my case at least. I did not have to copy SAM and SECURITY that are located there too. Vista could now successfully start.

I immediately upgraded to Windows 7 to prevent further issues with Vista or with this BSOD. To me this is like an in-place upgrade - getting a new engine in place of a failing one. Upgrading process replaces so many bits and pieces, here and there, thus providing me some confidence that I will not run into this BSOD again. I could also keep (probably) all or most of the installed software and not resort to a clean install. Upgrade process will advice which software need to be removed such as Skype. (Well, instead of removing, I updated Skype to the latest and it survived the Windows 7 upgrade nicely)

Hope this gives you some tips on what to try. I'll happily take feedback.

share|improve this answer
1  
It would be much easier if you simply posted what actually solved the problem for you instead of posting everything you tried. –  Baarn Feb 16 '13 at 20:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.