Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How to remove imesh from Firefox 3.6.

  1. Whenever I open new tab it loads page into it.
  2. If I type my search term in address bar it gives me results from

How can I remove it?

share|improve this question
up vote 1 down vote accepted

You could look through the extensions/add-ons configuration of Firefox, alternatively:

To uninstall iMesh and the iMesh Bar using the Windows Control Panel, please follow these steps:

  1. Click on the Windows "Start" menu in the lower left-hand corner of your screen.

  2. Click on "Settings" > "Control Panel" > "Add or Remove Programs".

  3. Select "iMesh 5" and click the "Remove" button.

  4. To uninstall iMesh Bar, repeat steps 1 to 3, selecting "iMesh Bar" and clicking the "Remove" button.

iMesh FAQ

share|improve this answer
I have uninstalled it, but when I click new tab in FF, it still opens page – user36912 Jan 30 '11 at 6:49
yes I also need to uninstall MediaBar thats by iMesh. thanks – user36912 Jan 30 '11 at 14:51
@user36912: You just need to set the start page to the default in the FF config. – Tom Wijsman Jan 30 '11 at 16:01

First uninstall iMesh using Add/Remove Programs like above.

If, like me, you find that uninstalling has not stopped searching with iMesh, change the options.

If you have done this and it's STILL searching using iMesh search when you search from the address bar or you are getting popups (like it did for me) then configure Firefox again using the following steps:

  1. In the address bar, type about:config - it will come up with a Firefox warning that says "here be dragons"
  2. Click on the button and continue.
  3. In the filter section type iMesh
  4. For all the filter results for iMesh, right click and hit reset
  5. Close Firefox and restart

This was the only thing that worked for me. I found it on a Firefox support question.

share|improve this answer

To emove imesh applications, go to my computer.

Click on "C". Click on Program Files. OPEN IMESH APPLICATIONS: the UNISTALL file is into this folder. Click and unistall Media Bar and all IMESH applications

share|improve this answer
  1. Un-install IMESH application in Control Panel / Add and Remove Programs
  2. Search "imesh" in C:\Program Files
  3. Delete All the file
  4. Test in Mozilla Firefox, and new tabs
share|improve this answer

protected by studiohack Apr 4 '11 at 9:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.