Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running up-to-date Debian Lenny for x86-64. I am using the iceweasel browser.

I browse to the web page crypto.org/blog and see the following:

Badly rendered fonts
Click for larger image

It looks like a ransom note! tHe texT iS VarYinG iN SiZe (except that the letters are all lower case, differing in size by about a point and a half).

It renders fine on all other browsers. (See for yourself.)

Please don't suggest installing the Microsoft fonts. I am looking to fix the problem rendering the existing fonts (that doesn't occur on other Debian-derived distros), not add new ones.

share|improve this question
1  
Please clarify whether the text varies in size (i.e. all lowercase letters, but letter height varies by some pixels), like you state in your question, or the text alters uppercase and lowercase, like you show in the example. Also, did you try to view the same page in another browser so you can be sure there's no defacing going on? –  jstarek Jan 30 '11 at 12:41
add comment

2 Answers

up vote 2 down vote accepted

Not all TrueType fonts are Microsoft fonts. The only Microsoft font package is ttf-mscorefonts-installer.

I suggest installing other TrueType fonts.

This will install all of them, except ttf-mscorefonts-installer (note the grep -v mscorefonts):

apt-cache search ttf | awk '/^ttf/ {print $1}' | grep -v mscorefonts | xargs apt-get install

Those other Debian derived distros (like Ubuntu) install all of the fonts by default. Debian doesn't. That's the difference.

share|improve this answer
    
This is not the only site that looks wrong. I want to make them all work. Supplying an additional font does not make that font the "default alternative" for the font this site specifies. If I install more fonts, I need to install fonts that will fix this. What font IS the browser picking for this site? (How do I tell?) Is that font actually ugly, or is there a rendering bug? Why would I have that bug in a default (Desktop role) Debian install? –  A Student at a University Jan 30 '11 at 21:35
2  
If you want to be conservative with some not very ugly fonts just install ttf-bitstream-vera. –  bahamat Jan 31 '11 at 4:22
add comment

Iceweasel menu : Edit > Preferences > Content > Fonts & Colors > Advanced > uncheck Allow pages to choose their own fonts, instead of my selections above.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.