Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My MacBook Pro suddenly has a problem with it's WiFi connection. When the Macbook is connected to WiFi, I cannot browse to any website. I can ping on the other hand, so that is not a problem. The connection seems there.

I cannot connect to any websites running on the local network. For example connect to the admin interface of my router, it DOES ask for the username and password, but after that it just keeps trying to connect.

My MacBook is connected to a WNDR3700 Netgear wireless router.

The following things I have tried:

  • Pinging hosts (that does work)
  • Performing trace route etc. (That seems to work)
  • Opening a manual telnet to some ports on my server (21, 80, 443) (that fails)
  • Changing browser (didn't solve it)
  • Connecting to another WiFi network (on the same wireless router) (didn't solve it)
  • Reinstalling my complete MacBook Pro (didn't solve it)

I have another (Windows) laptop, which has no problem using WiFi. Next thing I am gonna try now is resetting my router settings.

share|improve this question
Did u find a solution? My MBA starts to behave the same :( – Igor Spasic Feb 3 '15 at 10:17

I have had this issue before. For some reason the wireless link information becomes corrupted (I don't know how). These are the steps you can take to try and fix this:

  1. Open System Preferences
  2. Select Network
  3. Click the Lock and Enter your password to make changes
  4. Click on Advanced...
  5. Select the Airport tab if it isn't on it already
  6. Select your network name in the "Preferred Networks:" box
  7. Click the "-" icon to remove it
  8. Exit, and reconnect to your wireless network as if it is a new network.
share|improve this answer

Did you try different browsers? Try using another router. Could you provide the content of the routing table? Might it be related to HTTPS? If the login page of your router is loading successfuly, the url to verify the credentials might be secured by SSL (and probably by a self signed cert).

share|improve this answer
In the OP post it says tried "Changing browsers" and can connect using "another (Windows) laptop" It's doubtful that this is a router or browser problem. – aqua Jan 30 '11 at 9:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .