Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For a month or two now I've been using simple file sharing, for several months before that I didn't, then before that I had simple file sharing tuned on. So at the moment I don't have a security tab (on files or folders) or sharing permissions settings there too.

As an example, from another machine, I can access files from 2007 but not from the summer of last year in the same folder.

I can access all files on that local machine.

So I think I just need to re-apply security or permissions somehow? What should I do?

share|improve this question

4 Answers 4

up vote 2 down vote accepted
+50

Turn off simple file sharing, reset the permissions, turn it back on. According to Microsoft changing permissions while Simple File Sharing is off will still affect permissions even after it is turned back on:

A file's permission may differ from the parent folder if one of the following conditions is true:

  • You use the move command at a command prompt to move a file into the folder from a folder >on the same drive that has different permissions.
  • You use a script to move the file into the folder from a folder on the same drive that has >different permissions.
  • You run Cacls.exe at a command prompt or a script to change file permissions.
  • Files existed on the hard disk before you installed Windows XP.
  • You changed a file's permissions while Simple File Sharing was turned off on Windows XP >Professional.

Note NTFS permissions are not maintained on file move operations when you use Windows Explorer >with Simple File Sharing turned on.

If you turn on and turn off Simple File Sharing, the permissions on files are not changed. The >NTFS and share permissions do not change until you change the permissions in the interface. If >you set the permissions with Simple File Sharing enabled, only Access Control Entries (ACEs) on >files that are used for Simple File Sharing are affected. The following ACEs in the Discretionary >Access Control List (DACL) of the files or folders are affected by the Simple File Sharing

Source

share|improve this answer
    
+1 for the extra info –  ChrisF Feb 1 '11 at 17:20
    
OK, but which permissions ? –  Jules Feb 1 '11 at 18:34
    
also how to apply these permissions ? –  Jules Feb 1 '11 at 18:40
    
@jules turn off simple file sharing, right click the folder, go to properties, under the security tab allow permissions for everyone or the user accessing them. –  Kyle Feb 1 '11 at 18:59
    
@jules I don't quite understand what you are saying. Is the security tab not there on the second one? If it is, under advanced on the security tab of the root folder is there a check box to pass on inheritable permissions to subfolders? Also try giving the 'everyone' full permissions we can work on restricting it after we get it working with everyone. –  Kyle Feb 1 '11 at 19:50

Two possibilities spring to mind:

You will need to turn simple file sharing off, update the permissions and then turn simple file sharing back on.

Alternatively check the user accounts you are using to make sure that they are in the same workgroup and have the same passwords on both machines.

share|improve this answer
    
What permissions would I need to update? –  Jules Feb 1 '11 at 18:33
    
also how to apply these permissions ? –  Jules Feb 1 '11 at 18:41

Although ChrisF's answer would fix this, I just want to leave some useful information...

When necessary, the following tools can help in troubleshooting such issues:

  • AccessChk
    Shows you the accesses the user or group you specify has to files, ...

  • AccessEnum
    This simple yet powerful security tool shows you who has what access to directories, files and Registry keys on your systems. Use it to find holes in your permissions.

  • Process Monitor
    Monitor file system, Registry, process, thread and DLL activity in real-time.

    Set a filter on the ACCESS DENIED column and look at the properties of the events.

share|improve this answer

According to your information, the permissions of the folder allow access, but some files in the folder have different permissions.

The simplest solution would be to propagate the permissions of the folder to all the files and sub-folders that it contains, as follows :

  1. Turn off Simple File Sharing
  2. In Windows Explorer, right-click the folder and select Properties, then the Security tab
  3. Click Advanced
  4. Click Edit
  5. In the Advanced Security Settings, select both "Replace all existing permissions on all descendants" and "Include inheritable permissions from this object's parent"
  6. If a Windows Security dialog appears, click Yes to continue
  7. Click OK twice
  8. Turn Simple File Sharing back on
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.