Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My adsl box (the Freebox revolution of the french provider Free) has a hard drive inside which is accessible like a NAS storage.

With my home computer, I can easily access the nas storage using \freebox. With my work laptop (which is joined to a corporate domain), I cannot access the nas storage using \freebox. When I type \freebox in windows explorer, my Windows 7 prevents me this is maybe a attempt to compromise my security, and ask me credentials (there is no credentials required on the nas). If I type directly the IP adress, \192.168.X.X, I can access to the NAS with no problem. If I ping Freebox, the correct IP address is resolved (and is responding).

Do you any clue to solve this problem ?

share|improve this question
    
on your work computer lan properties do you have any options unchecked? –  rzlines Jan 30 '11 at 12:08

2 Answers 2

up vote 3 down vote accepted

One thing to verify is in
Administrative Tools / Local Security Policy / Local Policy / Security Options
if "Network security: LAN manager authentication level" is set to "Send LM & NTLM - use NTLMv2 session security if negotiated".

Since this solved your problem, then this means that the Freebox Revolution doesn't support newer NTLM security protocols. This setting means :

Clients use LM and NTLM authentication and use NTLMv2 session security if the server supports it; domain controllers accept LM, NTLM, and NTLMv2 authentication.

In other words, the Freebox only supports the older NTLM protocol, not NTLMv2 (version 2).

share|improve this answer
    
that actually solved the problem. Thanks ! Do you have any background information about this ? I'd like to understand what has been done :) –  Steve B Jan 30 '11 at 12:29
    
@ Steve B: If you want to know more about the policy you edited, browse to the policy again and hit the explain tab - all the options are explained comprehensively there. –  rzlines Jan 30 '11 at 12:45
    
Added some more useful info and links. –  harrymc Jan 30 '11 at 12:46
    
thanks for the precision. The freebox runs on a custom linux, I imagine the manufacturer has implemented the simpliest security option, (the goal is to have a media player, not a secure storage system) –  Steve B Jan 30 '11 at 12:53
    
Right, except that "simpler" -> "older". –  harrymc Jan 30 '11 at 19:16

I think freebox requires you to be on a particular network domain/workgroup in order to access its resources. And since your home computer and work computer are on different networks this might be the security threat that Windows detects

You might have to put in your admin credentials for that network. Try your home computer user name and password might do the trick though I can't be sure.

Another approach you can try is to edit your hosts file, since you can access Freebox by typing a static IP, you can make an appropriate entry that will define a url of your choice to access your NAS.


For eg:

192.168.0.2 is the ip of freebox.

The url can be anything so maybe just freebox

192.168.0.2  freebox
share|improve this answer
    
The freebox name is actually resolved : ping freebox Pinging freebox [192.168.X.X] with 32 bytes of data: Reply from 192.168.X.X: bytes=32 time=12ms TTL=64 and there is no password set on the nas –  Steve B Jan 30 '11 at 12:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.