Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So somehow my wife has hit a series of keys on her Apple bluetooth keyboard where none of the keys work except for JKL, which now display 123. UIO displays 456 and 789 display normally. This indicates to me that it is stuck in some sort of numlock mode but for the life of me I can't find anything where someone indicates the correct way to "unstuck" it. It's one of those newer ones without a keypad and without a visible numlock key. Does anyone have any ideas?

EDIT: An update. If I bring up the keyboard viewer and click the Capslock key while physically pressing the Fn key, it fixes itself. Once I log out it goes back to the way it was, however.

share|improve this question
1  
Just as an aside, I have tried fn+F6 without success. –  MattC Jan 30 '11 at 18:06
    
What OS are you using? –  Daniel Beck Jan 30 '11 at 18:13
    
OSX version 10.6.6 –  MattC Jan 31 '11 at 2:48
    
Have you tried taking the batteries out or unpairing the keyboard? –  Daniel Beck Jan 31 '11 at 3:22
    
Yes, I have. No dice. –  MattC Jan 31 '11 at 3:33

2 Answers 2

Apparently you have the following problem: Mouse Keys are turned on. Turn them off under System Preferences > Universal Access.


The other option you could try is to remove the batteries from the keyboard, or disconnect and reconnect it. That might reset the thing.

Alternatively, have you rebooted the Mac at all since this happened?

share|improve this answer
    
I just checked and it's off. However the problem remains. –  MattC Jan 31 '11 at 3:13
    
I have made a couple of new suggestions. I realise from reading your question that you've tried re-pairing the device, but the batteries might make a difference. –  user3463 Jan 31 '11 at 4:11
    
Yep, did the battery change thing too. –  MattC Jan 31 '11 at 14:43
    
I'm pretty sure I've done a reboot. I'll make sure to give that a try tonight just to make sure, though. –  MattC Jan 31 '11 at 14:44

I had exactly the same problem on an apple bluetooth keyboard I paired with my fedora desktop. However, fn + F6 fixed this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.