Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a weird problem from a long time ago already.

If I try to rename a file from "myfile.txt" to "MYFILE.txt" and vice versa, nothing changes. The filename still says "myfile.txt".

I tried to rename with Terminal, still nothing. Is this about FS? I have non-case-sensitive HFS+.

What can be the problem?

Update: upgrade osx to 10.6.6 , bug is gone in this version. =)

share|improve this question
Cannot reproduce. Mac OS X 10.6.6 – Daniel Beck Jan 30 '11 at 18:25
Cannot reproduce on my 10.6.6 either. Which version are you using? – user3463 Jan 30 '11 at 19:52
10.6.6 version, people tell me shell command to test with and I'll post a result.. =) for now I tried in finder and tried with "rename" util from linux (compiled my self) – holms Feb 4 '11 at 21:55
ah ok it's fixed, I remembered I upgraded osx few days ago now this bug is gone thnx you guys – holms Feb 4 '11 at 21:56
Note that this is only fixed through hacks in OSX's tools (e.g. /bin/mv). The filesystem is still hopelessly broken (case-insensitive but case-retaining), so things like GNU mv and other not-hacked-for-OSX will still have this problem. Terrible decision by Apple that can't be fixed because too many commercial OSX apps rely on the bad design. – Jim Stewart Jul 25 '13 at 15:49
up vote 0 down vote accepted

Upgrade Mac OS X to 10.6.6. I'm not able to reproduce there (both in Finder and Terminal), and neither is @RandolphPotter:

$ touch foo
$ ls
$ mv foo FOO
$ ls
$ mv FOO Foo
$ ls
share|improve this answer
I'd love to know what's wrong with this answer. As @bahamat stated, it seems to be an issue with OS X that was fixed with or before 10.6.6. The user has unfortunately not stated his OS version. According to OmniGroup statistics, two thirds of all Mac OS X machines are running Snow Leopard, making this answer very likely a practical and simple solution to the user's problem. – Daniel Beck Jan 30 '11 at 23:52
The user may have have a PPC system that can't upgrade past 10.5. I wasn't the one that voted you down, but I would guess this is why. – bahamat Jan 31 '11 at 4:24
@bahamat Could be. But the percentage of that is even lower than the 1/3 of people you need to at least pay the 29$ for SL, seeing as Intel Macs were introduced five years ago. Thanks for the suggestion though. – Daniel Beck Jan 31 '11 at 4:26
is there's any change that this doesn't work on usb drives with NTFS? because it DOESNT! – holms Mar 28 '11 at 1:45
@holms OS X cannot write to NTFS. The file system itself is case-preserving but case-insensitive, so the driver you're using might not rename, since there's already a file by the new name. I'm guessing here though. – Daniel Beck Mar 28 '11 at 5:11

I think you answered this yourself. Your filesystem is not case sensitive. Your rename operation doesn't look like a rename to the filesystem since none of the characters are changing.

If you really want to make it show up in all caps in the Finder then rename it to something else completely (like foo.txt) then rename it back with caps.

share|improve this answer
As I commented earlier, cannot be reproduced on 10.6.6 even with a case-insensitive file system. On what (operating/file) system were you able to reproduce this? – Daniel Beck Jan 30 '11 at 19:31
Then he's obviously not using 10.6.6 is he?. It doesn't mean that my workaround won't work. I remember this bug from earlier OS X versions but I don't remember when it was fixed. – bahamat Jan 30 '11 at 19:35
Not necessarily, bahamat. Let's see which version he's on before we make assumptions. – user3463 Jan 30 '11 at 19:52
OS X is case-insensitive, but it is also case preserving. – NReilingh Jan 30 '11 at 20:55
people im using 10.6.6 , ok tell me SHELL command to test with... and ill post a result to you – holms Feb 4 '11 at 21:54

You can reformat in a HFS+ case sensitive if you'd like. Is what I usually do because you can get in trouble with svn, git. But there is a drawback, some application doesn't work with a case sensitive FS.

share|improve this answer
Most prominently, probably everything by Adobe. – Daniel Beck Jan 31 '11 at 20:14
Not only, I add some VPN tools that didn't work. I had to go in the Content/MacOS to rename some file over there. But this trick probably won't work for other app. – mathk Jan 31 '11 at 20:17
Having software fail for a reason like this -- the drawback of this solution (IF it works at all -- on 10.6.6 it works without being case-sensitive, so that might not even be the issue, therefore my answer) is probably just too big to be practical. – Daniel Beck Jan 31 '11 at 20:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .