Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I run iPhoto 09 on snow leopard it hangs after displaying the main window. The "beach ball" goes on forever and I have to force quit.

Anybody knows what might be going on?

share|improve this question
1  
What have you tried to resolve this problem? –  user3463 Jan 30 '11 at 19:49
    
Disconnecting the iphone, running again, reboting... –  Fernando Jan 30 '11 at 20:59
    
Can you try launching with the option key pressed and see if you can select/create another library? –  Daniel Beck Jan 30 '11 at 21:14
    
You can also try moving the file ~/Library/Preferences/com.apple.iPhoto.plist temporarily to the desktop. This causes iPhoto to reset to default preferences. –  Daniel Beck Jan 30 '11 at 21:16

1 Answer 1

Same problem here, but not able to sort it out yet. Mine happened after accidentally interrupting an import from my iPhone.

Possible solutions:

None of these have so far worked for me: iPhoto starts up, seems fine (displays all of my images) but beachballs as soon as I click in the photo library pane, or try and import an image in to a clean library.

Other possible solutions I've seen mentioned.

I am on 10.6.6 / iPhoto 9.1.1 (= iPhoto '11) - around 10k images in the library.

Sources of information are linked, but arg, can only post two, so will add follow up comments with additional ones.

share|improve this answer
1  
I edited your post to include reference URLs. [7] and [9] are identical, is that correct? –  Daniel Beck Mar 30 '11 at 11:54
    
Yup - when I wrote this, I couldn't find a way to link to specific comments in the thread on the apple site. Looks like that's fixed now, will edit link 7 –  mildlydiverting May 16 '11 at 15:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.