Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

TextWrangler has always worked great, but now it's hanging everytime I open it.

I suspect one of the files it's trying to open causes a problem.

Is there a way to run it without opening any files?

share|improve this question
up vote 4 down vote accepted

Your TextWrangler preferences are stored in ~/Library/Preferences/ in:

  • the file com.barebones.textwrangler.plist
  • the files in the directory com.barebones.textwrangler.PreferenceData

I don't know which of the files contains the open documents. Move the files/folder to your desktop and try starting it, then put them back one after another to find the source of your problem.

share|improve this answer
    
It looks like it was com.barebones.textwrangler.PreferenceData/Saved Application State.appstate – Jason S Jan 30 '11 at 23:18

You can press and hold the Shift key while launching TextWrangler to suppress all normal startup actions, including reopening files.

share|improve this answer
    
This still works as of Dec 31, 2014 in BBEdit 11.0.2. Great tip. – eddieroger Dec 31 '14 at 20:54

mv ~/Library/TextWrangler/Saved Application State-023BCD4D-6979-5237-893B-7DE068E1516A.appstate Saved Application State-023BCD4D-6979-5237-893B-7DE068E1516A.appstate_bkp

This resolved issue for me.

Note that the state id will be different in your m/c

share|improve this answer

Go to TextWrangler > Preferences > Application and uncheck the box that says "Reopen documents that were open last quit"enter image description here

share|improve this answer
    
Sorry, this wouldn't have worked: I couldn't do anything in TextWrangler at all -- it hung immediately upon opening. Also I want it to reopen documents that were open at last quit. – Jason S Jan 31 '11 at 15:36
    
What did work then? I was merely addressing the question asked "Is there a way to run it without opening any files?" – Sable Feb 1 '11 at 16:12
    
Deleting the preference file responsible for restoring documents on opening worked. @Jason's problem was he couldn't open the editor because of this, so there was no way to get into its preferences dialog. – Daniel Beck Feb 2 '11 at 13:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .