Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For the life of me, I cannot figure out why set relativenumber does not load when set in my .vimrc file. Other settings, like set number and setting the color scheme work perfectly. If I want set relativenumber, I need to set it in the current buffer explicitly. Any ideas? My .vimrc file can be found here:


share|improve this question

1 Answer 1

up vote 11 down vote accepted

It's because you have :set number later in your .vimrc -- number and relativenumber are incompatible with one another. Take out that line.

share|improve this answer
Thanks, it worked! I had no idea they were mutually exclusive. I thought number turned on numbering while relativenumber made it relative. – mhamrah Jan 31 '11 at 1:06
Note, this is no longer true, as of version 7.3.787. Recent versions of Vim allow you to set both options at the same time; in that case the current line number will show an absolute value, every other line will show relative values. – Ben Sep 21 at 14:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.