Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In our house we have about 5 PCs; no DHCP Server or DNS Server.

We have a few portable backup drives (Western Digital WD1001FALS 1 TB drives) that we mount to Thermaltake SATA drive readers.

Any folder I create on one of these drives using my Windows 7 PC is created with me as the owner. Now, the other Win7 and WinXP PCs can not access it.

If I right click and go into Sharing, I can specify who on my PC to share with.

I don't want to share the folder. I want this to be just a folder. This is so frustrating.

Even if I share it with Everyone on my PC as Read/Write, none of the other PCs can access it because they are not an account from my PC.

I've tried asking on Microsoft's website, but it has been a week and I haven't received an answer. Maybe the SO community knows, and perhaps this will be something useful for others.

Luke from Stack Overflow (the place I generally hang out) suggested I come here. He further said I should be able to add an inheritable ACL granting "Everyone" access to the root folder of the drive.

But this is just a simple portable drive. Do I really have to create an access control list for a portable drive? Why is Windows insistent on creating an owner for it?

I just want this to be like any other "plug it in and go" USB drive.

share|improve this question
    
Have you tried reformatting the drive (as NTFS)? Right-click it on My Computer and select "Format". I've never had this problem with external NTFS drives. –  Juliana Peña Jan 31 '11 at 15:51
    
Make sure you are not encrypting the drive on accident! –  Jeff F. Feb 1 '11 at 21:42
add comment

3 Answers 3

up vote 4 down vote accepted

First of all, it is important to understand the distinction between sharing and file permissions. In Windows, you set up sharing to create a network share. When you add users to the sharing permissions, you are giving those users the ability to access that share remotely from another computer. From your description, it doesn't sound like this is what you're trying to do.

File permissions are separate, and dictate which users can see a file. They are also referred to as ACLs, or "access control lists". Every file and folder has an ACL, which specifies which users are permitted to do what with that file.

ACLs keep track of users by their SID. An SID is a string of characters which uniquely identifies each user and group on the computer. Even if you rename a user, their SID remains the same; likewise, if you have two users with the same username on two different computers, their SIDs are going to still be different.

A few "special" accounts and groups have the same SID on every system. These are system-level accounts in the NT AUTHORITY domain. If you give permissions to one of these accounts, those permissions persist across all Windows computers. This is what you'll want to do.

Right-click on the drive and choose Properties. Go to the Security tab - not the sharing tab.

file security properties

Click edit. You should have a list of the users who currently have permissions on this drive. Click Add, and type Everyone in the box, then hit enter. The account "Everyone" should now be shown. Click the checkboxes to give it full control, then click OK.

file security edit

Next, click Advanced, then Change Permissions. Check the box for "Replace all child object permissions with inheritable permissions from this object". This will assign the permissions you just created to all folders on the drive. Click OK. It will take a while for the permissions to propogate. Then, click OK until you've dismissed all the dialogs.

advanced file properties

This should give Everyone full access to all folders on the drive on all computers. If that for some reason doesn't work (though it should, as I've done this before), post in the comments and we can try to figure out what's going on.

share|improve this answer
    
Based on prior comments, I suspect this is still just applied to an everyone group on the local system. –  Joel Coehoorn Feb 1 '11 at 22:05
    
@Joel Coehoom It should still work everyone means "everyone" so there are effectively no permissions. @nhinkle is simply pointing out that he needs to apply folder/file level permissions as well as sharing permissions for everyone. By the way Excellent Answer @nhinkle! –  Kyle Feb 2 '11 at 0:11
    
@JoelCoehoorn, if you reread my section on SIDs and system-level groups, you'll see that "everyone" does apply to all computers. If you'd like to read more technical documentation on it, see "Managing Authorization and Access Control on MS TechNet. It explains all of this and more in great detail from a conceptual level. –  nhinkle Feb 2 '11 at 2:49
    
I believe it's supposed to, but I think he might have a bug/glitch of some kind that's preventing it from working –  Joel Coehoorn Feb 2 '11 at 3:20
    
But... Why do I have to do this? Folders created on a flash or portable drive are generally accessible on another PC. Did I mistakenly enable something? Is there a way to disable this feature that assigns permissions when I create a folder? I understand having folder permissions under C:\Users, but not elsewhere. –  jp2code Feb 3 '11 at 16:05
show 1 more comment

You should be able to add an inheritable ACL granting "Everyone" access to the root folder of the drive.

share|improve this answer
    
But this is just a simple portable drive. Why do I have to create an access control list for a portable drive? Why is Windows insistent on creating an owner for it? –  jp2code Jan 30 '11 at 23:30
    
Because every Windows file has an owner, even if that is the local service account. The OS doesn't know your intentions in wanting the files to be world-readable and why would it assume the unsafe option? They assume the safer option and force you to explicitly override it. –  T.Rob Jan 31 '11 at 3:21
1  
Because the filesystem is NTFS, and ACLs are NOT optional. If you don't want to deal with ACLs at all you could reformat it as FAT32, but you would lose some functionality (the most obvious being limited to a maximum 4GB file size). –  Luke Jan 31 '11 at 14:51
add comment

Have you tried setting the sharing permissions to Everyone Read/Write? Right-click a folder, go to the sharing tab, click the Share button. This will open the File Sharing window. Click the dropdown arrow to select "Everyone" and click the add button. Then click on the Read permissions level to change it to Read/Write.

File permissions

You could also try taking ownership of a folder:

You must have ownership of a protected folder in order to access it. If another user has restricted access and you are the computer administrator, you can access the folder by taking ownership.

To take ownership of a folder, follow these steps:

  1. Right-click the folder that you want to take ownership of, and then click Properties.

  2. Click the Security tab, and then click OK on the Security message (if one appears).

  3. Click Advanced, and then click the Owner tab.

  4. In the Name list, click your user name, or click Administrator if you are logged in as Administrator, or click the Administrators group. If you want to take ownership of the contents of the folder, select the Replace owner on subcontainers and objects check box.

  5. Click OK, and then click Yes when you receive the following message: You do not have permission to read the contents of directory folder name. Do you want to replace the directory permissions with permissions granting you Full Control? All permissions will be replaced if you click Yes. Note folder name is the name of the folder that you want to take ownership of.

  6. Click OK, and then reapply the permissions and security settings that you want for the folder and its contents.

share|improve this answer
    
I've tried that on this PC (D630). Then I go to another PC (EBMC) and I see that it is shared with "D630\Everyone" but I still can not access it with "EBMC\Everyone". –  jp2code Jan 31 '11 at 13:25
2  
The problem there is that "Everyone" refers to every user on D630. If you're logging in from EBMC as a user that doesn't exist on D630, it won't work. If it is a different user name it will usually ask you for a user name and password, but if it is a user that exists on both PCs, but has different passwords, it will usually just fail. I think you can add Anonymous to the list which should prevent the need to authenticate. –  Tofystedeth Jan 31 '11 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.