Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Ubuntu on VirtualBox can only show resolution of 800x600 - how to change it?

No matter what I do I cannot get the resolution past 800x600. If I am using a Windows install in VirtualBox, I can get it to 1024x768.

What is limiting me from doing this in Linux?

share|improve this question

migrated from stackoverflow.com Jan 31 '11 at 0:42

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Sathya Feb 3 '11 at 13:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
funny this is the duplicate when it was created 2 years prior.. –  Nick Stinemates Jun 18 '13 at 21:27
    
look here askubuntu.com/a/489948/287960 –  Gangnus Jun 30 at 11:32

2 Answers 2

up vote 28 down vote accepted

Have you installed the VirtualBox Guest Additions on your guest yet? If so, then the size of the guest should reflect the size of your VirtualBox window, so if you maximise the latter, your guest should resize its display accordingly.

You may also need to activate VirtualBox's Auto-resize Guest Display option (Host-G is a hot key for that).

share|improve this answer
    
helpdeskgeek.com/linux-tips/… may be of use if you're having trouble installing guest additions. –  Graphain Feb 7 '11 at 21:16

If installing guest additions does not solve the problem for you try the following:

sudo apt-get install virtualbox-ose-guest-x11

And some more info on the problem here: http://forums.virtualbox.org/viewtopic.php?f=3&t=33645&start=0

share|improve this answer
    
That one actually have worked form me. +1 –  rafek Jan 30 '11 at 18:30
    
Worked for me (remember to reboot). Alternatively see helpdeskgeek.com/linux-tips/… –  Graphain Feb 7 '11 at 21:16
1  
+1 Worked for Gentoo host and Ubuntu 14.04 guest. The package name seems to have changed to virtualbox-guest-x11 –  NigoroJr Jun 26 at 3:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.