Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7, 32-bit: There is 1 user account in this PC, and that is my account.

What I do is, I right click to a folder and uncheck the read only option, apply, close. After when I reopen the folder's properties I see that it is restored and file is still read only.

What should I do?

share|improve this question
    
Have you considered opening up process monitor and seeing who's setting the readonly bit? –  Billy ONeal Jan 31 '11 at 1:51
    
can you give details?, I am using windows in another language, so I couldn't find the process monitor, do you mean ctrl + alt + del ? –  sprsr Jan 31 '11 at 12:29
add comment

6 Answers

From your question it seems this issue is on folders, and you do not mention any inability to access these files. If this is the case the below should apply to you:

Unlike the Read-only attribute for a file, the Read-only attribute for a folder is typically ignored by Windows, Windows components and accessories, and other programs. For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer. The Read-only and System attributes is only used by Windows Explorer to determine whether the folder is a special folder, such as a system folder that has its view customized by Windows (for example, My Documents, Favorites, Fonts, Downloaded Program Files), or a folder that you customized by using the Customize tab of the folder's Properties dialog box. As a result, Windows Explorer does not allow you to view or change the Read-only or System attributes of folders. When a folder has the Read-Only attribute set it causes Explorer to request the Desktop.ini of that folder to see if any special folder settings need to be set. It has been seen where if a network share that has a large amount of folders set to Read-only, it can cause Explorer to take longer then what is expected to render the contents of that share while it waits on the retrieval of the Desktop.ini files. The slower the network connectivity to the share the longer this process can take to the point where Explorer may timeout waiting for the data and render nothing or appear to hang.

I have run into the issue you are describing in the past where you uncheck the box and after closing and opening properties again it is still checked. The above is what I found when looking into this issue. Source

share|improve this answer
add comment

I've spent a lot of time trying to make my folders not read only too. Even talked to my computer support staff and they were unable to resolve it. Guess what! There wasn't anything to fix.

Did Google search and found out that while files restrict changes when it's read only, folders that are read only are read only so different programs know how to treat them (it's a bit technical for me to explain more, since that's all I understand). Kyle's answer has the more technical details about it all.

But the real eye opener was this website which had pictures. Seems that even though the read only box has a little square in it - it isn't read only. Just when the box has a check mark in it, is it read only. So all this time and energy and they weren't even read only and even if they were, it's only important to the programs to know.

Hope this is the case with you and they aren't read only, so you won't have to worry. Cheers! Here's the pictures telling which are and aren't read only.

http://www.sevenforums.com/tutorials/63741-read-only-file-folder-attribute.html

share|improve this answer
add comment

Try using the attrib tool from the command prompt. You can type attrib /? to see usage guidelines.

Try this:

attrib -r -s c:\YourFolder /S /D

-r means remove readonly attribute -s means remove system attribute /S means process files and all subfolders /D means process folders also

share|improve this answer
    
I just ran into the same issue as the OP. Applying this commandline fix had no effect. –  estanford Aug 20 '12 at 15:43
add comment

Are you checking files or folder? Windows ignores read-only attributes for folders. If you un-check the read-only checkbox for a folder, it just appears greyed out the next time you open the folder properties. Check the "Cause" section of this KB article: http://support.microsoft.com/kb/326549

share|improve this answer
    
It is not grayed out, there is a blue squere at read only section, and It remains when I reopen the folder properties. –  sprsr Feb 1 '11 at 16:44
add comment

I had a similar issue yesterday, you can try this on the folders in question:

Right click your folder
Select properties
Hit the security tab
Click the Advanced button
Click the Owner tab
Click Edit
Highlight your username
Check "Replace owner on subcontainers and objects" 
Select OK, OK

Then you can go in and check the NTFS permissions under Properties -> Security and and ensure you have full control. This should solve your files being read only.

share|improve this answer
    
it didn't work, read only section is still checked. Does the "replace owner on subcontainers and objects" checkbox should remain checked ? Because it doesn't stay so. And after I check it and apply, it says something like (I am translating from another language because my windows is not english) If you have taken the ownership of this object not so long ago, you need to close and reopen properties of this object. –  sprsr Feb 1 '11 at 17:20
    
Can you open the files in the folder for editing? That is the main question. Because the blue square you speak of is normal, stated in a way below. What exactly are you trying to accomplish that you cannot? –  Dan M. Feb 1 '11 at 17:29
    
I am tring to install a cms, which is named magento, and it doesn't pass the configuration step. In the forums I searched it seems to be related with the file permissions and when I looked at the files, I saw that there is blue square in all files. That is what I am after. I am tring the blue square vanish because it may be related for my cms to be installed. –  sprsr Feb 1 '11 at 17:48
    
I doubt that is really the issue, the blue square. Also check out this thread for proper installation procedures. I think this may have more to do with that than anything else: magentocommerce.com/boards/viewthread/71211 –  Dan M. Feb 1 '11 at 18:28
add comment

Could you be looking at a SSD that's reached the end of it's rated life and gone into read-only mode?

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. –  Raystafarian Aug 1 '13 at 18:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.