Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

problem:

when i try to paste with middle click, the middle mouse button is ignored. in other cases middle click is also ignored.

my set up:

VMWare workstation 7.1.3

Host: windows 7 64-bit

Guest: existing partition of Ubuntu 10.10. I have a dual boot (ubuntu,win7) from win7 i log into the ubuntu's partition.

Hardware: ThinkPad x201 Tablet

side question: does virtualbox has the same problem?

share|improve this question
    
I should have asked if you can use the middle mouse click when you dual boot into Ubuntu directly. –  wag2639 Jan 31 '11 at 3:13

4 Answers 4

up vote 1 down vote accepted

You can fix this by disabling TrackPoint scrolling in the Windows control panels.

I had the same problem in a VMware Ubuntu guest on a ThinkPad X220 running Windows 7. With the default mouse/trackpoint settings, the middle button wouldn't register at all when running xev in Ubuntu. Presumably some low-level Windows/Lenovo software layer was capturing middle-button events and interpreting them as scroll commands.

You can resolve this by turning off scrolling altogether. In the mouse control panel, you can set TrackPoint scrolling to either "Scrolling," "Magnifying Glass," or "Neither." I was able to paste in Ubuntu using the middle button right after setting the control to "Neither."

share|improve this answer

Ubuntu/Gnome doesn't natively treat the middle mouse button as a scrolling wheel. I think it does something odd like paste from clipboard.

You'll need to configure it manually.

For a graphically utility, you can install GPointing Device Settings by running

sudo aptitude install sysfsutils

See: http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint

share|improve this answer

After many painfull months without linux middle button action I decided to insist on finding a solution for my lenovo T510, Win7 host, debian guest.

After hours of trying and search, I finally found it: The "Neither" setting as described by Alan alone is not enough for my model (and I assume for other's too). You also have to set the "scrolling type" (for me, in the "settings" next to the "Neither" setting) to "smooth" !

Thanks UltraNav/Lenovo for offering all kinds of patented obscure scrolling with you eye-lashes-options and thereby rendering the settings rediculously complex.

share|improve this answer

While Alan and docno jointly have written a complete answer satisfying the question. It does not fix "Control Scrolling" which is scrolling you do when holding the middle button and moving the trackpoint to scroll a page.

After a few hours of research I found that you can fix this by letting virtualbox completely propagate the USB device (your keyboard) to the guest. This solution has one advantage:

  • The keyboard will be seen directly by the guest and at least on Ubuntu the USB keyboard works right away out of the box. This is not the case for Windows nor OS X according to my own experience.

There is some very serious drawbacks:

  • Keyboard becomes totally dead to the host! You can't even use the Host Key in virtualbox anymore! However, you can if you have a separate physical keyboard nearby (like the one integrated in your laptop or any other USB keyboard).
  • Mouse integration will stop working! altogether. You can however just disable it in VirtualBox with Ctrl+I
  • Your host will think you're completely idle when using the ThinkPad USB keyboard and the Host's srceensaver will go in on you. It scared the hell out of me when the screen just went dark! Naturally this is just resolved by lengthening the the time limit.

I wish I had seen this earlier as I wouldn't had to download any Windows drivers for my USB keyboard in the first place.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.