Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently replaced a dying D-Link router with a Cisco/Linksys RSV4000. I'm really happy with the device but it seems when my cable modem is plugged in to it I lose 1/3 of my download speed. When I plug the modem right into my desktop I get 30mb/s down and 5mb/s up, but going through the router I get 20mb/s down. I tried turning off every option in the router to see if that had an effect since at work we can’t use an http proxy with Comcast because their boost service doesn’t work with it for some reason but that didn’t change anything. I never had this problem with the old D-Link.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

The fix for this was turning off IPS, turns out there's an underpowered CPU in this POS so the 800Mb/s throughput they claim is BS. Here's a link with some more info about it http://www.dslreports.com/forum/r18508174-RVS4000-Speed-problems-explained

share|improve this answer
add comment

check the MTU that you get when connected either way.

the wrong MTU will change your throughput negatively.

Also, your machine may incorrectly do a path mtu discovery whne the cisco is helping.

And the dratted thing my be screwing your TCP window size.

check the MTU usiig ipconfig /all on windows, ifconfig on *ix

check the window size using ethereal or wireshark while web browsing or downloading.

share|improve this answer
    
I'm not sure how ipconfig /all helps in finding the MTU as it's not listed for me (Win7x64). I did find this command though, netsh interface ipv4 show subinterfaces, which tells me I'm set to 1500. Another webpage said you can ping with a set packet size untill it fails and that's how big it is, which gives me 1472 then. Manually setting either value in the router didn't change anything though, still missing 1/3 of my download speed. –  Brian Surowiec Aug 19 '09 at 4:05
    
try to set it to 1400 on your pc. –  Tim Williscroft Aug 19 '09 at 4:57
    
Set it to 1400 on both the router & the desktop and still nothing. I'm thinking it's time to call Linksys or Cisco about this. –  Brian Surowiec Aug 20 '09 at 1:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.