Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After my computer is on for about an hour or so the network printers stop responding (I can no longer see any of the printers). Any attempts I make to print results in non-response by whatever program I am using (Acrobat Reader, MS Word, etc.)

Restarting my computer restores my ability to print, but it is only a temporary fix.

Does anyone know what the problem is or how I can fix it?

share|improve this question
up vote 1 down vote accepted

Could be the spooler service running into issues. On Windows 2003 I've run into an issue with the service crashing for some reason pretty much daily.

Next time it happens, try restarting the spooler service.

From the command prompt:

net stop spooler
net start spooler

From the services.msc snap-in it's called "Print Spooler"

From the task manager process list, there's a process called "spoolsv.exe" which you can kill off if Windows is unable to stop it gracefully.

FYI, you can reproduce the issue where you're not able to see any printers by stopping the spooler service.

share|improve this answer
I tried to 'net stop spooler' and it errored out: "System error 5 has occured. Access is denied." Any ideas? – Alex Feb 17 '11 at 2:12
Access is probably denied. Are you logged in as administrator? – Ciaran Feb 17 '11 at 9:16
I logged on as admin and it started. Thanks! – Alex Feb 18 '11 at 16:14
Good stuff. This will probably start to annoy you after a while though. You might be able to see what's causing it to stop working if you look at the event viewer (start > run > eventvwr) – Ciaran Feb 18 '11 at 20:33

Are you using your computer during the hour, or is it sitting idle for a time? It could be that your network card is slowing or powering down when not in use and not coming back up properly. We have had this issue in regards to losing connection to exchange and not being able to get it back until a reboot is performed (even though other network services are still accessible)


  1. Open device manager (though control panel or the management console, which ever you prefer)
  2. Find your network adapter and double click on it.
  3. Go to the Power Management tab and uncheck "Allow the computer to turn off this device to save power."

Note, that is the wording found on my machine, your specific adapter may have slightly different options in the power management tab, but there should be something to that effect in there.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .