Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I keep getting the "sorry, the maximum allowed clients from your host (10) are already connected" error whenever I try to transfer a large number of files. At first I thought it's a filezilla bug, however I get the same error basically with every FTP client I've tried, including Total Commander under Wine. I do not get that error using Windows. I did try to limit maximum allowed connections for Filezilla, both in server settings and in global settings, it didnt change anything. I did try to switch between passive and active modes (not sure if it's related at all, just last desperate attempt), and it didnt change anything either.

When I try to use native ftp client (not sure how is it called, the one in Places -> Connect to a server) I get abstract "connection refused" error every time I transfer large number of files. Connection is refused for separate particular files, if I click "Ignore" each time the rest of files are transfered perfectly well, so I assume it's the very same error.

Anything I could do? This really drives me mad, transfering large numbers of files is a part of my everyday job...

P.S. and this happens with many different FTP servers. Also I dont get this error in Windows. So I assume it's not a server problem. P.P.S. I am aware of similar question here, the answer provided just didn't solve it to me.

share|improve this question
Are you having this problem connecting to a specific FTP server? Do you have control over this server? It sounds like the server has the limit, so changing your client settings won't make one iota of a difference. But more information will be useful. – user3463 Feb 1 '11 at 7:07
I get this connecting to a few different servers (basically every server I need), and I do not have control over the server. Yes the server has the limit apparently, so I want my client to obey that limit or something. And I doubt the server settings needs any change because all works fine from windows clients. – Sejanus Feb 1 '11 at 8:14
Have you tried lowering the number of simultaneous transfers and concurrency in FileZilla? – Xenoactive May 7 '11 at 1:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.