Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Windows 7. Now I have the computer going to sleep every 2 minutes or so. It turned out that the wireless keyboard I am using is the problem. How do I fix this? Btw, both the keyboard and mouse from microsoft.

share|improve this question
1  
How did you conclude that the wireless keyboard is the problem? Have you tried increasing the sleep timeout in the power settings? –  Bobby Alexander Feb 1 '11 at 6:50
    
@Bobby I removed the keyboard and mouse, the problem went away! –  fastcodejava Feb 2 '11 at 2:25

2 Answers 2

Try changing your power management settings in the control panel and see if that has any issue. I haven't heard of the keyboard or mouse affecting this, but perhaps by adjusting these settings you might find some changes.

share|improve this answer

If it's the keyboard, I would guess the sleep button on the keyboard is stuck. But, to troubleshoot down further, remove the keyboard and see if the computer still falls asleep. If it does, w7pro's answer would be the correct one imho. If it doesn't, the sleep button may be stuck.

share|improve this answer
    
There is sleep button. See my comment above. –  fastcodejava Feb 2 '11 at 7:27
    
I would try looking either in the driver for the keyboard to see if you can turn the sleep button off, or sometimes there's a setting in your BIOS power management that disables the keyboard's ability to power off your computer. Or alternatively try going into your Power Configuration in windows and under the "When Standby Button is Pressed" choose "Do Nothing". –  Duall Feb 2 '11 at 14:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.