Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

During execution of an SQL Query in MySQL Workbench, the query is automatically limited to 1000 rows. How does one prevent the tool from imposing this limit?

share|improve this question

1 Answer 1

up vote 35 down vote accepted

You need to add your own LIMIT clause to then end of your query.

Use a number greater than the possible number of items that will be returned, say LIMIT 100000.

Source: http://wb.mysql.com/?p=230#comment-1279


Update:

(Using version 5.2.29CE, not sure how up to date I am):

On the menu bar visit Edit -> Preferences.

Jump to the SQL Queries tab.

In the Query Results section at the bottom untick the Limit Rows option.
You can adjust the limit to a higher value from this location as well, if that is preferable.

share|improve this answer
    
Thank you, @DMA57361 –  Brian Hooper Feb 1 '11 at 13:11
    
@BOB: You might actually want to post this as your own answer - its substancially different from the original answer, and well, this worked at some point –  Journeyman Geek Nov 22 '12 at 9:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.