Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The power went out (again) in my house today so I decided to set up some alerting. Since I have a ReadyNAS and the latest version of Raidinator seems to have SMTP TLS support, I figured I would try setting things up to email to a domain I have hosted on Google Apps.

At this point, I have everything working IF I use a Gmail account but as soon as I switch to a Google Apps email address, it stops working and complains with

smtpstatus=535 smtpmsg='535-5.7.1 Username and Password not accepted. Learn more at                   \n535 5.7.1 http://mail.google.com/support/bin/answer.py?answer=14257 30sm16076226wfd.23' errormsg='authentication failed (GNU SASL, method PLAIN)' exitcode=EX_NOPERM

I'm wondering if anyone else has encountered this. Google's extremely aggressive captcha does not help but I am able to log in now without a captcha from a browser so I'm open to any ideas why the simple switch of a user/password combo that is supposed to work does not.

I'm also attaching my config so that others can see how to set things up.

alt text

share|improve this question

3 Answers 3

Check out: http://mail.google.com/support/bin/answer.py?hl=en&answer=13287

I would try SSL if the mail client supports it.

I would advise against thijs recommendation to use port 25 for 2 reasons:
1) All data is sent in the clear (not so much a problem as its just you and your ISP and Google)
2) Many ISPs are starting to block port 25.

share|improve this answer

I was using the wrong login information from one of my Google accounts. Ensure that when you use your credentials that they are the master credentials for that Google account.

All the information above worked seamlessly.

My settings were:

port 587
user----username@gmail.com
Pass XXXXXXXXX

I changed the Login Type on my ReadyNas to login instead of Auto and I have checked the use Tls AND use STARTTLS boxes as well.

share|improve this answer

set the SMTP server to aspmx.l.google.com, port 25 and don't use TLS or login

And make sure the email adress is one of the adresses on the domain wich is hosted by google.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.